ABBYY FlexiCapture
System Administrator’s Guide
**Table of Contents**

**Installing ABBYY FlexiCapture**

- Standalone Installation ................................................. 5
- System Requirements .................................................. 5
- Installation methods ................................................... 5
- Interaction of the system components ................................ 5
- Manual (interactive) installation ...................................... 5
- Command line installation ............................................. 6

**Distributed Installation** .................................................. 7

- System Requirements .................................................. 7
- General information .................................................... 15
- Preparing the Application Server for installation on Windows 2012 .................................................. 15
- Preparing the Application Server for installation on Windows Server 2008 R2 ............................................. 16
- Installing the servers .................................................... 19
- External components required for the correct operation of the system .................................................. 20
- System components in IIS and their configuration ............... 21
- Database server ........................................................ 34
- Interaction of the system components ................................ 35
- Installing the stations .................................................... 35

**Using Active Directory** .................................................. 37

- Example: Deploying ABBYY FlexiCapture using Active Directory .................................................. 37

**Using SMS** ................................................................. 40

- Example: Deploying ABBYY FlexiCapture using Microsoft SMS .................................................. 41

**Installing Remote Stations** ............................................. 44

- Upgrading from ABBYY FlexiCapture 9.0 and 10 ................. 45
  - Updating projects created in a standalone edition of ABBYY FlexiCapture (*.fcpri) ............................................. 45
  - Updating projects and databases created in a distributed edition of ABBYY FlexiCapture ...................................... 45
  - Using ABBYY FlexiLayout Studio 9.0 or 10 projects (*.fsp) .................................................................................. 67
  - Using FlexiLayouts (*.afl) created in ABBYY FlexiLayout 9.0 or 10 .................................................. 67

**Managing Your Licenses** .................................................. 48

- Overview ........................................................................... 48
- ABBYY FlexiCapture 11 License Manager ......................... 48
- License properties .......................................................... 48
- License statuses ........................................................... 49

© 2014 ABBYY Production LLC. All rights reserved.
Setting Up ABBYY FlexiCapture Distributed Installation........................................51

How is activation carried out?................................................................................49
Connecting stations to the Licensing Server .........................................................50

Quick setup of ABBYY FlexiCapture for demonstration installations....................51
Detailed setup of ABBYY FlexiCapture ..................................................................51
How to choose the user authentication type.........................................................51
Creating a database .................................................................................................52
Connecting to an existing database .......................................................................55
Uploading a project to the server ...........................................................................56
Creating new users ..................................................................................................56
Setting up user roles and access rights .................................................................59
Configuring the Processing Server .......................................................................59

Oracle database settings .........................................................................................61
Web stations’ settings ..............................................................................................63
Security settings in ABBYY FlexiCapture Distributed ...........................................64
Recommendations for setting up ABBYY FlexiCapture .......................................65
General recommendation .......................................................................................65
Using performance counters ..................................................................................68

Logging.....................................................................................................................74
Administration and Monitoring Console logs .......................................................74
Task processing logs on the Processing Servers .....................................................74
OS event logs on the servers ...................................................................................74

Working with Clusters............................................................................................75
Setting Up the Processing Server ..........................................................................75
Deploying the Processing Server on a Failover Cluster .........................................75
Setting Up the Licensing Server ............................................................................94
Setting Up the Application Server (and clustering the Administration and Monitoring Console and Web Stations) ..............................................................94
Setting Up an NLB Cluster for the Application Server ..........................................94

Technical Support....................................................................................................97
Installing ABBYY FlexiCapture

Before purchasing the product, analyze your document processing needs and select either the local or the distributed version.

If you plan to process moderate amounts of documents (approximately 5,000 pages per day), employ one or two operators for the job, and do not require any sophisticated batch routing, then **Standalone Installation** is the best choice.

If you plan to automate data capture and processing, require sophisticated batch routing based on document or batch types, and need a scalable pool of centrally administered workstations, then select **Distributed Installation**.

**Note:** When installing the program under Windows Vista, Windows Server 2008 or newer operations systems, the UAC should be disabled before installation or the native administrator account must be used.

**Important!** The distributed and local versions cannot be installed on the same computer.

### Standalone Installation

#### System Requirements

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz
- Memory: 512 MB for each CPU core, but no less than 1 GB
- Hard disk space: 1.5 GB (including 1 GB for installation)
- Scanner supporting TWAIN, WIA or ISIS
- Video card and display with a resolution of 1024×768
- Microsoft .NET Framework 3.5 SP1

#### Installation methods

The following installation methods are available to install the standalone version of ABBYY FlexiCapture:

- manually (interactive installation)
- from the command line

#### Interaction of the system components

The following figure displays the system component interaction for standalone installation:

![Diagram](image.png)

If you have one license and several operator stations, then for connecting operator stations to the Licensing Server, the 10041 port has to be opened manually in Firewall settings.

### Manual (interactive) installation

To install the standalone version of ABBYY FlexiCapture:
1. In the Autorun menu, select **Standalone Installation** (you can run the autorun.exe file manually).

2. Select a setup language. The setup program will compare the locale of your system and the selected language. If the languages are incompatible, a warning message is displayed.

3. Next, the setup program checks the version of your operating system and the availability of the administrative permissions. If the version of the operating system is not supported by the program or you do not have the administrative permissions, a warning message is displayed and the setup program is terminated.

4. If all the checks are passed successfully, the end-user license agreement will be displayed. Read the license agreement carefully and if you agree with the terms of the agreement, select the corresponding option and click **Next**.

5. A dialog box will open prompting you to enter some information about yourself. Enter the required information and continue with the installation.

6. In the next dialog box, select one of the available installation modes:
   - **Administrator Station** – The setup program installs the Administrator Station, FormDesigner, and FlexiLayout Studio.
   - **Operator Station** – The setup program installs only the Operator Station. (The Administrator Station, FormDesigner and FlexiLayout Studio will not be installed).
   - **Administrator and Operator Stations** – The setup program installs the Administrator Station, the Operator Station, FormDesigner and FlexiLayout Studio. By default this configuration is installed.

7. Next, select a destination folder. By default, the program is installed to `%systemdrive%\Program Files\ABBYY FlexiCapture 11`. If there is not enough space on the selected hard disk, a window is displayed showing your hard disks, the available free space, and the space required by the installation. Select a disk with sufficient free space and continue with the installation.

8. The program files will be copied onto your computer. Once the installation is finished, the setup program will display a message saying that the application has been successfully installed.

9. **License Manager** will be launched automatically so that you can activate your serial number. See the "Managing Licenses" section for details.

**Note:** For information about configuring multiple workstations to work with a single license server, see [Connecting stations to the Licensing Server](#).

**Command line installation**

In the default configuration, all recognition languages are installed on the local computer and the interface language is selected automatically based on the regional settings of the computer on which the program is installed. By default, the **Administrator and Operator Stations** installation mode will be selected (see above).

Run the `setup.exe` file located in the administrative installation folder using the command line options described below.

**Advertise installation**

For advertise installation, type

```bash
Setup.exe /j
```

The ABBYY FlexiCapture icon will appear in the **Start** menu. Clicking this icon automatically installs the program in default configuration.

**Silent installation**

In the case of silent installation, no setup dialog boxes are displayed and the program is installed in default configuration.

```bash
Setup.exe /qn
```

Change "/qn" to "/qb" if you want an installation progress bar to be displayed.

No other dialog boxes will be displayed.

**Additional command line options**

`/L<language code>` disables auto selection of the interface language and installs the program with the interface language you specified.

The following **language code** values are available:

- 1033  English
- 1049  Russian
/V <command line> passes the specified command line directly to msiexec.exe. The <command line> string can be replaced with the following commands:

**INSTALLDIR=**"<destination>" – the path to the folder where ABBYY FlexiCapture is to be installed.

**SETUPTYPE_CMD=**"<install mode>" – available installation modes.

The following modes are available:

- Full – Administrator and Operator Stations
- Admin – Administrator Station
- Operator – Operator Station

**Note:** See the previous section for a description of the available installation modes.

Example:

```
Setup.exe /qn /L1049 /v INSTALLDIR="D:\FC11" SETUPTYPE_CMD=Full
```

As a result, the Administrator and Operator Stations will be installed into **D:\FC11**, and Russian will be used the language of the interface.

**Removing ABBYY FlexiCapture in silent mode**

```
msiexec /x {uninstall registry key}
```

The location of the uninstall registry key:

```
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall
```

You can also determine the Product ID by executing the following command in the command line:
```
"wmic product where "Name like '%FlexiCapture%'" get Name, Version, IdentifyingNumber".
```

### Distributed Installation

#### System Requirements

**Servers**

**Application Server**

- PC with Intel® Pentium®/Celeron®/Core™ 2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz. The use of processor which has 2 or more cores is recommended for Application Server.


- Memory: no less than 2 GB for Application Server and 4 GB for MS SQL Server

- Hard disk space: 100 MB for installation, 2 GB for SQL Server database. Additional space is required for the file storage.

- The computer where the server is installed must be connected to your domain

- Internet Information Server 7 or higher.

- Microsoft .NET Framework 4.0 (4.5 if running under Windows Server 2012)

- Microsoft SQL Server 2005 SP2, 2008 SP1, 2008R2 SP2, 2012 SP1, 2014

  **Note:** Microsoft Azure SQL is not supported.

- Oracle 10g, 11g or 12c

**Administration and Monitoring Console**

- Video card and display with a resolution of 1024×768

- Internet Information Server 7 or higher.

- Microsoft .NET Framework 4.0 (4.5 if running under Windows Server 2012)

- Crystal Reports for Visual Studio 2010 (Version 13, 13.0.11.1467 is recommended), Crystal Reports 2008 (Version 12), Crystal Reports for Visual Studio 2008 (Version 10.5)

- Internet Explorer 7, 8, 9, 10 or 11.
**Note.** To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

**FlexiCapture Authentication Module**

- Internet Information Server 7 or later
- Microsoft .NET Framework 4.0 (4.5 if running under Windows Server 2012)

For operation of Web Module for login and registration one of the following web browsers is required:

- Internet Explorer 7, 8, 9, 10 or 11. Browser security settings: Internet Explorer medium-high protection level. If high protection level is used, the following option must be specified explicitly:
  - Active scripting = Enable

**Note.** To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

**Note.** The Metro-style version of Internet Explorer 10 that comes with Windows 8 is not supported.

**Note.** Internet Explorer 64-bit is only supported under Windows 7/2008+ if Silverlight 5 is installed.

- Mozilla Firefox 14 or later (32-bit). Security settings for Mozilla Firefox:
  - Java scripting = Enable
- Google Chrome 20 or later (32-bit). Security settings for Google Chrome:
  - JavaScript = Allow all sites

**Processing Server**

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: no less than 2 GB
- Hard disk space: 100 MB for installation
- Video card and display with a resolution of 1024×768
- The computer where the server is installed must be connected to your domain

**Licensing Server**

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: no less than 2 GB
- Hard disk space: 100 MB for installation
- The computer where the server is installed must be connected to your domain

**Stations**

**Project Setup Station**

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 512 MB for each CPU core, but no less than 1 GB
- Hard disk space: 1.5 GB (including 1 GB for installation)
- Scanner supporting TWAIN, WIA or ISIS
- Video card and display with a resolution of 1024×768
- The computer where the station is installed must be connected to your domain
- Microsoft .NET Framework 3.5 SP1

Processing Station

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 512 MB for each CPU core, but no less than 1 GB
- Hard disk space: 1.5 GB (including 1 GB for installation)
- The computer where the station is installed must be connected to your domain
- Microsoft .NET Framework 3.5 SP1

Verification Stations

Verification Station

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 512 MB for each CPU core, but no less than 1 GB
- Hard disk space: 1.5 GB (including 1 GB for installation)
- Video card and display with a resolution of 1024×768
- The computer where the station is installed must be connected to your domain
- Microsoft .NET Framework 3.5 SP1

Remote Verification Station

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 1 GB
- Hard disk space: 100 MB
- Video card and display with a resolution of 1024×768
- Microsoft .NET Framework 3.5 SP1

Web Verification Station

- Video card and display with a resolution of 1024×768
- Silverlight 5.1.20913 or later. (Microsoft Internet Explorer 11 only supports SilverLight when running under Windows 7 SP1 or Windows 8.1).

One of the following web browsers:

- Internet Explorer 7, 8, 9, 10 or 11.

  Browser security settings: Internet Explorer medium-high protection level. Detailed required settings for Internet Explorer:
• Run ActiveX controls and plug-ins = Enable
• Script ActiveX controls marked safe for scripting = Enable
• Active scripting = Enable
• File Download = Enable (to install Silverlight)

**Note.** To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

**Note.** The Metro-style version of Internet Explorer 10 that comes with Windows 8 is not supported.

**Note.** Internet Explorer 64-bit is only supported under Windows 7/2008+ if Silverlight 5 is installed.
• Mozilla Firefox 14 or later (32-bit).
  Security settings for Mozilla Firefox:
  • Java scripting = Enable
  • Firefox will remember history (Tools -> Options -> Privacy) = Disable
• Google Chrome 20 or later (32-bit).
  Security settings for Google Chrome:
  • JavaScript = Allow all sites
  • Plug-ins = Run automatically
  **Note.** All plugins are disabled by default. To enable a plugin, open chrome://plugins/ in the browser and select the Always allowed option for the desired plugin.

### Data Verification Stations

#### Data Verification Station

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 1 GB
- Hard disk space: 100 MB
- Video card and display with a resolution of 1024×768
- Microsoft .NET Framework 3.5 SP1

#### Web Data Verification Station

- Video card and display with a resolution of 1024×768
- Silverlight 5.1.20913 or later. (Microsoft Internet Explorer 11 only supports SilverLight when running under Windows 7 SP1 or Windows 8.1).

One of the following web browsers:
• Internet Explorer 7, 8, 9, 10 or 11.
  Browser security settings: Internet Explorer medium-high protection level. Detailed required settings for Internet Explorer:
  • Run ActiveX controls and plug-ins = Enable
  • Script ActiveX controls marked safe for scripting = Enable
  • Active scripting = Enable
  • File Download = Enable (to install Silverlight)

**Note.** To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

**Note.** The Metro-style version of Internet Explorer 10 that comes with Windows 8 is not supported.
Note. Internet Explorer 64-bit is only supported under Windows 7/2008+ if Silverlight 5 is installed.

- Mozilla Firefox 14 or later (32-bit).
  Security settings for Mozilla Firefox:
  - Java scripting = Enable
  - Firefox will remember history (Tools -> Options -> Privacy) = Disable
- Google Chrome 20 or later (32-bit).
  Security settings for Google Chrome:
  - JavaScript = Allow all sites
  - Plug-ins = Run automatically
  
  Note. All plugins are disabled by default. To enable a plugin, open chrome://plugins/ in the browser and select the Always allowed option for the desired plugin.

**Scanning Stations**

**Scanning Station**

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 1 GB
- Hard disk space: 1 GB (including 200 MB for installation and space for scanned images)
- Scanner supporting TWAIN, WIA or ISIS
- Video card and display with a resolution of 1024×768
- Microsoft .NET Framework 3.5 SP1

**ClickOnce Scanning Station**

- PC with Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ with a minimum clock speed of 2 GHz.
- Memory: 1 GB
- Hard disk space: 1 GB (including 90 MB for installation and space for scanned images). The size of downloadable file is 41 MB.
- Scanner supporting TWAIN, WIA or ISIS
- Video card and display with a resolution of 1024×768
- Internet Explorer 7 or higher for ClickOnce deployment
  
  Note. To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.
- Microsoft .NET Framework 3.5 SP1

**Web Scanning Station**

- Video card and display with a resolution of 1024×768
• Scanner supporting TWAIN. WIA scanners are visible to the station but they are not guaranteed to work.
• Silverlight 5.1.20913 or later. (Microsoft Internet Explorer 11 only supports SilverLight when running under Windows 7 SP1 or Windows 8.1).

One of the following web browsers:
• Internet Explorer 7, 8, 9, 10 or 11.
  Browser security settings: Internet Explorer medium-high protection level. Detailed required settings for Internet Explorer:
  ▪ Run ActiveX controls and plug-ins = Enable
  ▪ Script ActiveX controls marked safe for scripting = Enable
  ▪ Active scripting = Enable
  ▪ File Download = Enable (to install Silverlight)

  **Note.** To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

  **Note.** The Metro-style version of Internet Explorer 10 that comes with Windows 8 is not supported.

  **Note.** Internet Explorer 64-bit is only supported under Windows 7/2008+ if Silverlight 5 is installed.
• Mozilla Firefox 14 or later (32-bit).
  Security settings for Mozilla Firefox:
  ▪ Java scripting = Enable
  ▪ Firefox will remember history ([Tools] -> [Options] -> [Privacy]) = Disable

• Google Chrome 20 or later (32-bit).
  Security settings for Google Chrome:
  ▪ JavaScript = Allow all sites
  ▪ Plug-ins = Run automatically

  **Note.** All plugins are disabled by default. To enable a plugin, open chrome://plugins/ in the browser and select the **Always allowed** option for the desired plugin.

The table below lists the operating systems on which the ABBYY Scanning Plug-In can be installed with various permissions.

<table>
<thead>
<tr>
<th>OS</th>
<th>Permissions</th>
<th>UAC</th>
<th>CAB</th>
<th>EXE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Server 2003 SP2</td>
<td>Administrator</td>
<td>-</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>User</td>
<td>-</td>
<td>✓</td>
<td>✓*</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Installation is forbidden by default</td>
</tr>
<tr>
<td>Windows XP SP3</td>
<td>Administrator</td>
<td>-</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>User</td>
<td>-</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Internet Explorer 8 or higher is required</td>
</tr>
<tr>
<td>Windows Vista SP2, Windows Server 2008 SP2</td>
<td>Administrator</td>
<td>Yes</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 7 SP1, Windows Server 2008 R2 SP1</td>
<td>Administrator</td>
<td>Recommended</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>---------------</td>
<td>-------------</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>User</td>
<td>Recommended</td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 8/8.1</td>
<td>Administrator</td>
<td>Recommended</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>User</td>
<td>Recommended</td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows Server 2012</td>
<td>Administrator</td>
<td>Recommended</td>
<td>×</td>
<td>✓** Installation is forbidden by default</td>
</tr>
<tr>
<td>No</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows Server 2012 R2</td>
<td>Administrator</td>
<td>Recommended</td>
<td></td>
<td>No</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------</td>
<td>-------------</td>
<td>---------------------</td>
<td>--------</td>
</tr>
<tr>
<td>User</td>
<td>Recommended</td>
<td>×</td>
<td>✓**</td>
<td>Installation is forbidden by default</td>
</tr>
<tr>
<td>No</td>
<td>×</td>
<td>✓**</td>
<td>Installation is forbidden by default</td>
<td></td>
</tr>
</tbody>
</table>

*Note: To allow the ABBYY Scanning Plug-In to be installed by users, select the **Disable Windows Installer option (select Computer Configuration -> Administrative Templates -> Windows Components -> Windows Installer)** and set it to **Never**.

**Note:** To allow the ABBYY Scanning Plug-In to be installed on Windows Server 2012, run the executable file Setup.exe as Administrator or change the security policy by setting the value of the registry key HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer DisableMSI to "0".

**Note:** For detailed instructions on how to install the ABBYY Scanning Plug-In, see Web Scanning Station Help.

**Web Capture Station**

- Video card and display with a resolution of 1024×768
- Scanner supporting TWAIN. WIA scanners are visible to the station but they are not guaranteed to work.
- Silverlight 5.1.20913 or later. (Microsoft Internet Explorer 11 only supports SilverLight when running under Windows 7 SP1 or Windows 8.1).

One of the following web browsers:

- Internet Explorer 7, 8, 9, 10 or 11.

Browser security settings: Internet Explorer medium-high protection level. Detailed required settings for Internet Explorer:

- Run ActiveX controls and plug-ins = Enable
- Script ActiveX controls marked safe for scripting = Enable
- Active scripting = Enable
- File Download = Enable (to install Silverlight)
Note. To insure that Internet Explorer 11 works correctly, install .NET Framework 4.5 on the computer with the Application Server or add the address of an application server to the list of websites that are opened in compatibility mode.

Note. The Metro-style version of Internet Explorer 10 that comes with Windows 8 is not supported.

Note. Internet Explorer 64-bit is only supported under Windows 7/2008+ if Silverlight 5 is installed.

- Mozilla Firefox 14 or later (32-bit).
  Security settings for Mozilla Firefox:
  - Java scripting = Enable
  - Firefox will remember history (Tools -> Options -> Privacy) = Disable

- Google Chrome 20 or later (32-bit).
  Security settings for Google Chrome:
  - JavaScript = Allow all sites
  - Plug-ins = Run automatically

  Note. All plugins are disabled by default. To enable a plugin, open chrome://plugins/ in the browser and select the Always allowed option for the desired plugin.

For operation of Web Capture Station, ABBYY Scanning Plug-In must be installed. Installation restrictions are listed in the table. For detailed instruction on how to install ABBYY Scanning Plug-In, see Web Scanning Station help.

**Supported virtual machines**
The following virtual machines are supported:

- VMware Server 2.0 (this platform is no longer supported by the manufacturer)
- VMware Workstation 6.5 - 9.0
- VMware ESXi 4.1.0 (server component of VMware vSphere)
- Hyper-V 6.0, 6.1 or 6.2 (Hyper-V version corresponds to the version of the operating system. Under Windows Server 2008, Hyper-V 6.0 is used.)

Note: Hyper-V virtual machines do not work with USB devices. VMware ESXi virtual machines work with Wibu drivers only, iKey drivers are not supported.

**General information**
Server operation system like Microsoft Windows Server 2008, 2008R2, 2012 should be used for server part of ABBYY FlexiCapture installation.

The distributed installation of FlexiCapture includes three servers:

- Application Server
- Licensing Server
- Processing Server

The Application Server coordinates the work of the stations ensures the correct operation of ABBYY FlexiCapture.

The following three steps are required to install the distributed version of ABBYY FlexiCapture:

1. Prepare the Application Server.
2. Install the servers.
3. Install the workstations.

**Preparing the Application Server for installation on Windows 2012**
These instructions can also be used when installing the Application Server on Windows 8.

The following components must be installed on your computer before you can install the Application Server:

- .Net Framework 4.0
- IIS (Internet Information Services)
- This component can be installed by selecting Install External Components in the Autorun menu.

The .Net Framework 4.5 component is installed by default on Windows 2012 and Windows 8. Information about the installed versions of .Net Framework can be found in the Windows registry. For more information, please refer to the Microsoft website.
IIS is installed using the server administration console. Press the Add roles and features button and select the Web Server (IIS) value in the roles list to install IIS. You may need the Windows installation disk to perform this operation.

The following IIS components must be installed:

- .Net Framework 4.5 Features
- ASP.NET 4.5
- Web Server (IIS)
- Web Server
  - Common HTTP Features
    - Static Content
    - Default Document
    - HTTP Errors
    - HTTP Redirection
  - Application Development
    - .Net Extensibility 4.5
    - ASP.NET 4.5
    - ISAPI Extensions
    - ISAPI Filters
  - Security
    - Basic Authentication
    - Windows Authentication
    - Request Filtering
  - Management Tools
    - IIS Management Console
    - IIS 6 Management Compatibility
    - IIS 6 Metabase Compatibility
    - IIS 6 WMI Compatibility
    - IIS 6 Scripting Tools

You may also install other IIS components.

Preparing the Application Server for installation on Windows Server 2008 R2

This instruction can also be used when installing the Application Server on Windows 2008, Windows 7 and Windows Vista.

Important! Before you start, it is recommended to disable the UAC or to perform all actions using the native administrator account.

To disable UAC:

1. In Control Panel open User Accounts.

2. Click Change User Account Control settings link and in the dialog box that opens, decrease the level of user control to Never notify.
3. For changes to take effect, restart the computer after turning off UAC.

The Application Server coordinates the work of the stations and ensures the correct operation of ABBYY FlexiCapture. The following components must be installed on your computer before you can install the Application Server:

- .Net Framework 4.0
  Select Install External Components in the Autorun menu to install this component.
  **Note:** Information about the installed versions of .Net Framework can be found in the Windows registry. For more information, please refer to the Microsoft website.

- IIS (Internet Information Services)

The Application Server can only be installed on a computer on which Microsoft Internet Information Server 7 or later is installed. IIS is required for the correct operation of the Application Server, the Administration and Monitoring Console, and Web Stations.

To install IIS, do the following:

1. In **My Computer** local menu, choose **Manage**.
2. In the **Server Manager** console that opens, click **Add Roles** and from the roles list select **Web Server (IIS)**.
3. During installation, Windows may ask you for the source distribution files, so you need to have Windows installation CD.

4. Enable installation of the following IIS internal components:
   - Web Server
     - Common HTTP Features
     - Static Content
     - Default Document
     - HTTP Errors
     - HTTP Redirection
     - Application Development
     - .Net Extensibility 4.5
Other IIS components can be installed according to user preferences, e.g., perform a complete installation of IIS.

Installing the servers

Once you have made the preparations for installing the Application Server, install the servers. By default, all servers are installed on the same computer. However, you can install them on different computers by disabling the redundant servers in the setup program.

To install the ABBYY FlexiCapture servers:

1. In the Autorun menu, select **Distributed Installation**. Next, select **Install Servers** to start the installation.

2. Select a setup language. The setup program will compare the locale of your system and the selected language. If the languages are incompatible, a warning message is displayed.

3. Next, the setup program checks the version of your operating system and the availability of administrative permissions. If the version of the operating system is not supported by the program or you do not have the appropriate permissions, a warning message is displayed and the setup program is terminated.

4. If all the checks are passed successfully, the end-user license agreement will be displayed. Read the license agreement carefully and if you agree with the terms of the agreement, select the corresponding option and click **Next**.

5. A dialog box will open prompting you to enter some information about yourself. Enter the required information and continue with the installation.

6. Next, select the servers to install. You can also specify a destination folder. By default, the program is installed to: `%systemdrive%\Program Files (x86)\ABBYY FlexiCapture 11 Servers` (`%systemdrive%\Program Files\ABBYY FlexiCapture 11 Servers` if 32-bit OS version is used).
   - **Processing Server** – the server that controls the operation of the Processing Stations
   - **Licensing Server** – the server that stores and manages licenses. When you install servers on different workstations, you must specify the address of this server or the Licensing Server in the format `server`, without `\` or http:// (or IP-address)
   - **Application Server** – the server that controls the operation of the other components. When you install servers on different workstations, you must specify the address of this server or the Application Server in the format `server`, without `\` or http://
   - **Web Stations** – the Application Server components which allow operators to connect to the server and work using a web-browser.
   - **FlexiCapture Authentication Module** – the Application Server component which allows operators of Web stations to register with the system and create requests for access rights to the Web station. Provides operators of Web stations with a single entry point into the system. By default, this feature is not installed. For more information on how to choose the authentication method, please refer to [How to choose the user authentication type](#).
   - **Stations Installer** – selecting this option will copy the stations’ setup files onto the Application Server so that you can then deploy them from the server. SMS and Active Directory deployment are supported. Once you select this component, you can specify the destination folder where to copy the setup files.
7. Next, the setup program will check if .Net Framework 4.0 (or 4.5, if running under Windows Server 2012) and IIS are installed on your computer. If any of the components is missing on your computer, the setup program will display a warning message.

8. The program files will be copied onto your computer. Once the installation is finished, the setup program will display a message saying that the application has been successfully installed.

9. Once the installation is complete, License Manager will be launched automatically so that you can activate your serial number. See Managing Your Licenses for details. The Monitoring Station will also be launched, where you can set up the installed Application Server.

10. If you see an error message in the Administration and Monitoring Console, open the IIS Manager console (select Start -> Administrative Tools -> Internet Information Services (IIS) Manager) and check if IIS server and Default Web Site are running:

If the server is stopped, in the Manage Server menu, choose Start. Similarly, check whether Default Web Site is running.

IMPORTANT! The Application Server should be available on the Internet if you wish to use the remote stations over the Internet.

Removing ABBYY FlexiCapture servers in silent mode
msiexec /x {uninstall registry key}.

The location of the uninstall registry key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall (the Product ID is in the name of the subkey with the product name in its values). You can also determine the Product ID by executing the following command in the command line: “wmic product where “Name like "%FlexiCapture%”” get Name, Version, IdentifyingNumber”.

External components required for the correct operation of the system

- iKey driver

This component is required if you plan to use a license stored on an iKey USB dongle manufactured by Rainbow. On a 64-bit operating system, you must install a 64-bit version of iKey driver manually. It can be installed by selecting Install External Components in the Autorun menu.

On 32-bit operating systems, no additional steps are required to install the iKey driver, as it will be installed automatically.
• CodeMeter runtime
This component is required if you plan to use a license stored on a CodeMeter USB dongle manufactured by
Wibu-Systems. No additional steps are required to install the driver. Installation will be done automatically
when the Licensing Server is installed.

• Microsoft Core XML Services (MSXML6)
This component is required for the operation of the Application Server. It is installed automatically.

• Crystal Reports
This component is used by the Administration and Monitoring Console to generate reports. Crystal Reports
can be installed on the same computer where the Application Server is installed. Without this component,
you will not be able to generate reports. However, all other Application Server management functionality will
be available. ABBYY FlexiCapture supports Crystal Reports basic for Visual Studio .NET 2008 and Crystal
Reports 2010. Crystal Reports is not installed automatically and should be installed manually. A 32-bit ver-

tion of Crystal Reports basic for Visual Studio .NET 2008 can be installed by selecting Install External Com-
ponents in the Autorun menu.

Note: Whether to install a 32- or 64-bit version of Crystal Reports is determined by the mode, in which the
pool of the Administration and Monitoring Console is running in IIS (FlexiCapture 11 Monitoring). For details,
see “System components in IIS and their configuration.” By default the pool of Administration and Monitoring
Console runs in 32-bit mode. However, it can be transferred to 64-bit mode, which allows you to use Crystal
Reports 64-bit. For details, see “Switching system components to 64-bit mode.”

If the bit does not match or Crystal Reports is not installed, the following error message will appear:

A runtime error occurred:
CrystalReports loading failed
Details:
Description Exception has been thrown by the target of an invocation.
Source mscorlib
Stack trace at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean
noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) at Sys-
tem.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at Sys-
tem.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo
 culture, Object[] activationAttributes) at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr,
Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at Sys-
tem.Reflection.Assembly.CreateInstance(String typeName, Boolean ignoreCase, BindingFlags bindingAttr,
Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at
ReportManager.loadCrystalReports()

System components in IIS and their configuration
This section describes the IIS configuration which is required for the operation of FlexiCapture. This configuration is
selected automatically when you install the program. However, if any errors occur, the information in this section may
help you make sure that IIS is configured correctly.

Application pools
During the installation of the Application Server, the installer automatically adds three IIS application pools associated
with ABBYY FlexiCapture 11. Application pools enable interaction with workflows bound to one or more applications
and sharing data between them.

FlexiCapture 11 Monitoring  –  enables the operation of the Administration and Monitoring Console

FlexiCapture 11 Web Services  –  enables the operation of the Application Server.

FlexiCapture 11 Web Stations  –  enables the operation of the Web stations: Web Verification station, Web Data Veri-
fication station, and Web Capture station.

All pools are configured automatically during the installation of ABBYY FlexiCapture. Pool settings critical for correct
operation of the Application Server, are listed below:

- .Net Framework Version = v4.0
- Managed Pipeline Mode = Integrated
- Identity = NetworkService

ABBYY FlexiCapture application pools work in 32-bit mode. In IIS Manager Console, you can check if 32-bit mode is enabled. For this, do the following:

1. Run the IIS Manager Console by selecting Start -> Administrative Tools -> Internet Information Services (IIS) Manager.

2. Choose Application Pools.
3. Choose a desired pool from the list. In the Actions menu, select Advanced Settings…

The value of Enable 32-Bit Application must be True. It means that the pool works in 32-bit mode.

Besides, the installer adds the following applications to Default Web Site (the set of applications depends on the configuration selected during the installation):

Default Web Site\FlexiCapture11\Monitoring – the Administration and Monitoring Console
Default Web Site\FlexiCapture11\Server – the Application Server, in particular:

Default Web Site\FlexiCapture11\Server\WebServices.dll – a web service of the Application Server which supports both Windows and Basic authentication.

Default Web Site\FlexiCapture11\Server\WebServicesExternal.dll – a web service of the Application Server which supports authentication by means of the FlexiCapture Authentication Module (this will be added if FlexiCapture Authentication Module was selected during the installation of ABBYY FlexiCapture Servers).

Default Web Site\FlexiCapture11\Login – a Web-based interface for login and registration (this will be added if FlexiCapture Authentication Module was selected during the installation of ABBYY FlexiCapture Servers)

Default Web Site\FlexiCapture11\DataVerification – Web Data Verification Station (will be added if the Web Stations component is selected during the installation of ABBYY FlexiCapture Servers)

Default Web Site\FlexiCapture11\Verification – Web Verification Station (this will be added if the Web Stations component is selected during the installation of ABBYY FlexiCapture Servers)

Default Web Site\FlexiCapture11\Scanning – Web Scanning Station (will be added if the Web Stations component is selected during the installation of ABBYY FlexiCapture Servers)

Default Web Site\FlexiCapture11\Capture – Web Capture Station (will be added if the Web Stations component is selected during the installation of ABBYY FlexiCapture Servers)

Authentication settings for FlexiCapture Web Applications
To control access to the applications via http protocol, it is necessary to configure authentication settings (login/password-based connection verification of a user’s identity). For this, choose a desired application and then choose the Authentication item.

Then select a required authentication method from the list and enable it.
To access ABBYY FlexiCapture applications, different authentication types are used:

**Windows authentication** – a user tries to login to the server using the same credential under which the user browser runs. (Using UTF-8-encoded characters in the user name and the password may be not supported.) To pass Windows authentication, the user must be either a local user of the computer or a user of the domain which includes this computer.

**Basic authentication** – login and password are transmitted over the network in clear text. To pass Windows authentication, the user must be either a local user of the computer or a user of the domain which includes this computer.

**Anonymous authentication** – the server does not require the client to transfer the credential. Users accessing the server operate under a special local account, that is, they are considered local users and are authenticated on their computers.

**FlexiCapture Authentication Module (ABBYY FlexiCapture Authentication)** – user name and password are passed the same way as when using Basic authentication, authentication is performed against a FlexiCapture database which stores users’ logins and password hashes. To pass the authentication, it is necessary that the login and password of the account match the login and password specified in the FlexiCapture database. This makes it possible to use logins and passwords which are not related to Windows user accounts.

By default, the FlexiCapture Authentication Module is not installed during the installation of servers. In this case, the following authentication settings are specified in IIS:

**Default Web Site\FlexiCapture11\Monitoring** (Administration and Monitoring Console) - only Windows authentication:
Default Web Site\FlexiCapture11\Server (Application Server) - both Windows authentication and Basic authentication are enabled:
Default Web Site\FlexiCapture11\DataVerification (Web Data Verification Station) - only Anonymous authentication is enabled.

Default Web Site\FlexiCapture11\Verification (Web Verification Station) - only Anonymous authentication is enabled.

Default Web Site\FlexiCapture11\Scanning (Web Scanning Station) - only Anonymous authentication is enabled.

Default Web Site\FlexiCapture11\Capture (Web Capture Station) - only Anonymous authentication is enabled.

If the FlexiCapture Authentication Module was installed, the following authentication settings are specified in IIS:

Default Web Site\FlexiCapture11\Monitoring (Administration and Monitoring Console) - only FlexiCapture authentication is enabled for this folder and all its files and subfolders, except for the Default Web Site\FlexiCapture11\Monitoring\DBConnection.aspx page, for which only Windows authentication is enabled, and for the Server folder. For all pages, except for the DBConnection.aspx page, redirecting to the Default Web Site\Login page is configured in the case of the HTTP 401 error, which enables automatic switching to the login page if the user cannot pass the FlexiCapture authentication.

Default Web Site\FlexiCapture11\Server (Application Server) - Windows, Basic, and FlexiCapture authentications are enabled for this folder and all its files and subfolder, except for the Default Web Site\FlexiCapture11\Server\WebServices\External.dll file, for which only FlexiCapture authentication is enabled.

Default Web Site\FlexiCapture11\Login (Web-based interface for logging on existing users or registering new users) - only Anonymous authentication is enabled.

Default Web Site\FlexiCapture11\DataVerification (Web Data Verification Station) - only Anonymous authentication is enabled.

Default Web Site\FlexiCapture11\Verification (Web Verification Station) - only Anonymous authentication is enabled.
Handler Mappings

In IIS services, handlers process requests to sites and applications. The handlers are mapped to resources on a web server and create responses to those requests. Like the modules, the handlers are implemented using native or managed components, such as a dynamic DLL or managed code.

After the installation of ABBYY FlexiCapture Application Server, the installer performs the following actions:

1) Adds to IIS the mappings required for correct processing requests from the Application Server. These mappings can be viewed in the IIS Manager console. For this, select the Handler Mappings item for Default Web Site\FlexiCapture11\Server (the Application Server).

For correct operation of the Application Server, the installer creates a mapping “ABBYY FlexiCapture WebService” with the following parameters:

Request path = "*\.dll"

Executable = "C:\inetpub\wwwroot\FlexiCapture11\Server\WebServicesIsapi.dll"
Access = "Script"

**Note:** It may happen that a third-party application is installed on the same computer as the Application Server, and it can intercept requests of ABBYY FlexiCapture. In this case, the following error message will occur when starting the Administration and Monitoring console:

A runtime error occurred:

Cannot get file storage path

Details:

Description Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'. The request failed with the error message: -- Server Error in Application "DEFAULT WEB SITE/FLEXICAPTURE11/SERVER"Internet Information Services 7.5

Error Summary

HTTP Error 500.0 - Internal Server Error

There is a problem with the resource you are looking for, so it cannot be displayed. Detailed Error Information Module IsapiModule

Notification ExecuteRequestHandler
Handler Custom Handler
Error Code 0x8007007f
Requested URL http://127.0.0.1:80/FlexiCapture11/Server/WebServices.dll?Handler=Default
Physical Path C:\inetpub\wwwroot\FlexiCapture11\Server\WebServices.dll
Logon Method Negotiate
Logon User WORKGROUP\WIN-COSLCUOARGA$

In this case, a handler which intercepts the request to the Application Server is called Custom Handler.

2) For the Default Web Site\FlexiCapture11\Scanning and Default Web Site\FlexiCapture11\Capture applications, installs the level AccessPolicy = Read, Script (Execute = false). To set the parameter value manually, choose the application in the applications tree, go to the Handler Mappings section, and choose the Edit Feature Permissions command from the Actions menu.

ISAPI and CGI Restrictions
The installer of FlexiCapture servers creates an allowance for the ISAPI-extension of the Application Server.
To view the list of allowed ISAPI-extensions, at the upper level of the IIS Manager console (the level of IIS server) select ISAPI and CGI Restrictions.

"FlexiCapture 11 Web Services" extension (path "C:\inetpub\wwwroot\FlexiCapture11\Server\IsapiLoader.dll") must be allowed.
Checking the operation of IIS
To check the operation of IIS, start IIS by selecting Start ➔ Control Panel ➔ Administrative Tools ➔ Internet Information Services. If a problem occurs when starting IIS, the following message will be displayed: “The process cannot access the file because it is being used by another process.”

This error message means that port 80 is in use. To find out which application is using the port, do the following:

1. In the command line (Start ➔ Run), type netstat -anop TCP|find ":80"
The list of connections to port 80 will be displayed and the ID of the corresponding process in the following format:
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 1264

2. Type tasklist /SVC /FI "PID eq 1264” replacing 1264 with the ID of the process obtained at step 1. The result will be displayed in the following format:
   Image Name PID Services
   ===-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
   Virus.exe 1264 KillMePlz
   3. End the process that uses the port.

Important! Do not switch IIS over to another port, as you will not be able to start the Application Server in this case.

Switching system components to 64-bit mode
Important! This configuration is not recommended (e.g., pool of the Application Server (FlexiCapture 11 Web Services) does not work in 64-bit mode). In particular, when using Oracle as a database server, the Oracle client through which a connection to the database is performed must work in the same bit mode as both the pool of Administration and Monitoring console (FlexiCapture 11 Monitoring) and the pool of Application Server. If you switch the pool of Administration and Monitoring console to 64-bit mode, it will work in a different mode than the Application Server pool (which works in 32-bit mode). A possible solution is to install two identically configured Oracle clients one of which works in 32 bit mode and the other in 64 bit mode.

You may need to switch the pool of Administration and Monitoring console to 64-bit mode if you are using Crystal Reports x64 (a tool for generating reports), as they must work in the same bit mode, and using Crystal Reports x32 is not possible.

By default, the pool of the Administration and Monitoring console works in 32-bit mode. To switch it to 64-bit mode, do the following:

1. Open IIS Manager Console by selecting Start ➔ Administrative Tools ➔ Internet Information Services (IIS) Manager.
2. Choose Application pools.

3. From the list of pools, choose **FlexiCapture 11 Monitoring** and in the Actions menu, select **Advanced Settings...**
The value of **Enable 32-Bit Application** parameter must be **False**. It means that the Administration and Monitoring console works in 64-bit mode.

In addition, check if using of 64-bit version of ASP.net is allowed in IIS settings. For this, open the IIS Manager console and choose the IIS server. From the menu on the right, select ISAPI and CGI Restrictions.

Allow using ASP.NET v4.0.30319 for Framework 64-bit (path `C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll`
Database server

SQL

• For the Application Server to work, MS SQL Server is required (for the supported versions, see System Requirements). On the server, the “Mixed Mode” ("SQL server and Windows authentication") must be enabled for authentication. The installation CD contains MS SQL Server 2005 Express. It can be used for demonstration purposes and small projects. This version limits the database size to 4 GB. If another edition or a newer version of MS SQL Server is installed on your computer, you can use that edition or version.

Required SQL Server Collation: SQL_Latin1_General_CP1_CI_AS.

Note: Microsoft Azure SQL is not supported.

Oracle

• Instead of SQL Server, the Oracle Server can be used as a database server (for the supported versions, see System Requirements). For this, a 32-bit client for the Oracle database must be installed.

Important! By default, an Oracle database allows a maximum of 40 processes and 49 sessions. When these limits are reached, the following error message occurs: “ORA-12516: TNS:listener could not find available handler with matching protocol stack.”

If required, increase the default values by using a script similar to the following:

```sql
connect sys/<Login> as sysdba;
alter system set sessions=<SessionCount> scope=spfile;
alter system set processes=<ProcessCount> scope=spfile;
shutdown immediate;
startup;
```
Interaction of the system components

The following figure displays the system component interaction for distributed installation:

So the following ports have to be enabled:

- **Application Server** — 80 if HTTP is used or 443 if HTTPS is used
- **Processing Server** — 10022
- **Licensing Server** — 10041
- **Processing Station** — 10023

**Note:** It is recommended that you should disable the IPv6 protocol in the adapter properties, otherwise addresses of the hosts are not displayed correctly in the Administration and Monitoring Console.

Installing the stations

The following installation methods are available to install the stations:

- manually (interactive installation)
- from the command line
- using Active Directory
- using Microsoft Systems Management Server (SMS)

The automated installation methods give you speed and flexibility when installing ABBYY FlexiCapture on a local area network, as you do not have to install the program manually on each individual workstation.

**Manual (interactive) installation**

To install ABBYY FlexiCapture stations:

1. In the Autorun menu, select **Distributed Installation**.
2. Select **Install Workstations** to start the installation.
3. Select a setup language. The setup program will compare the locale of your system and the selected language. If the languages are incompatible, a warning message is displayed.
4. Next, the setup program checks the version of your operating system and the availability of the administrative permissions. If the version of the operating system is not supported by the program or you do not have the administrative permissions, a warning message is displayed and the setup program is terminated.

5. If all the checks are passed successfully, the end-user license agreement will be displayed. Read the license agreement carefully and if you agree with the terms of the agreement, select the corresponding option and click Next.

6. A dialog box will open prompting you to enter some information about yourself. Enter the required information and continue with the installation.

7. Next, select a destination folder. By default, the program is installed to: %systemdrive%\Program Files\ABBYY FlexiCapture 11 Stations

8. Select the stations to install:
   - Scanning Station scans documents and sends them to the server for further processing
   - Processing Station automatically recognizes, imports, and exports documents; controlled by the Processing Server
   - Project Setup Station is used to set up projects on the server and local projects
   - Data Verification Station is used to verify uncertainly recognized characters
   - Verification Station is used to verify data, correct document assembly errors, handle exceptions
   - FlexiCapture Studio is a tool for creating FlexiLayouts
   - FormDesigner is a tool for creating forms

   Just like the servers, the stations can be installed on the same or on different computers.

9. If a Processing Station is selected, a dialog box will appear where you must select the account under which the Processing Station service will run. By default, the service runs under the user NETWORK SERVICE. If you plan to import/export data on this station from/to a storage location with restricted user rights, or if this station is not in the domain, you can specify the user that has the appropriate rights. In this case, the Processing Station service will run under this user.

10. The program files will be copied onto your computer. Once the installation is finished, the setup program will display a message saying that the application has been successfully installed.

11. If FlexiLayout Studio, FormDesigner, Verification or Project Setup Station is installed, provide the name or the address of the Licensing Server in the next dialog box. The Licensing Server is installed via server installation. The name should not contain slashes, for example: MainServer

Command line installation
By default, all FlexiCapture stations will be installed. For the name of the Licensing Server, the setup program will specify the name of the computer from which the stations are being installed (in the case of local installation, localhost will be specified). Network Service will be specified as the user of the Processing Station. The interface language will be either English or the language specified in the regional settings of the operating system.
Run the setup.exe file located in the administrative installation folder using the command line options described below.

Advertise installation
For advertise installation, type
Setup.exe /j
The program icon will appear in the Start menu of the workstation. Clicking this icon automatically installs the program in default configuration.

Silent installation
In the case of silent installation, no setup dialog boxes are displayed and the program is installed in default configuration.
Setup.exe /qn
Change “/qn” to “/qb” if you want an installation progress bar to be displayed.
No other dialog boxes will be displayed.

Additional command line options
/L<language code> disables auto selection of the interface language and installs the program with the interface language you specified.

The following language code values are available:
/V <command line> passes the specified command line directly to msiexec.exe. The <command line> string can be replaced with the following commands:

INSTALLDIR="<destination>" – the path to the folder where ABBYY FlexiCapture 11 stations to be installed.

STATIONS=0,1,2,3,4,5,6 – the list of stations to install.

The numbers 0 to 6 correspond to the following stations:

0 – Scanning Station
1 – Processing Station
2 – Verification Station
3 – Data Verification Station
4 – Project Setup Station
5 – FlexiLayout Studio
6 – FormDesigner

ACCOUNTTYPE=Custom, LOGIN=user name, PASSWORD=password

You can specify an account under which to run the Processing Station service.

Example:

Setup.exe /qn /L1049 /v INSTALLDIR="D:\FC11" STATIONS=1,4 ACCOUNTTYPE=Custom

LOGIN=Domain\UserLogin PASSWORD=PSWD

As a result, the Processing and Project Setup Stations will be installed into D:\FC11, and Russian will be used the language of the interface. The Processing Station service will run under the account Domain\UserLogin and the password will be PSWD.

PROTECTIONSERVER=ServerName – the name of the Licensing server.

Removing ABBYY FlexiCapture stations in silent mode

msiexec /x [uninstall registry key].

The location of the uninstall registry key depends on the type of operating system.

32-bit system: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall

64-bit system: HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall

(the Product ID is in the name of the subkey with the product name in its values). You can also determine the Product ID by executing the following command in the command line: "wmic product where "Name like "%FlexiCapture%"" get Name, Version, IdentifyingNumber".

Using Active Directory

Microsoft® Windows® 2000 Server and later include an integrated directory service, Active Directory, which in turn includes Group Policy. The Software Installation snap-in, which is part of Group Policy, allows you to install a software application on several workstations simultaneously.

Three major installation methods are implemented in Active Directory: Publish to User, Assign to User, and Assign to Computer. ABBYY FlexiCapture can be installed using the Assign to Computer method. ABBYY FlexiCapture will be installed on the specified workstation after the workstation is restarted.

The Publish to User and Assign to User methods are not supported.

When deploying ABBYY FlexiCapture using Active Directory®, the account of the computers in the Domain Computers domain must have read right to the administrative installation folder.

Example: Deploying ABBYY FlexiCapture using Active Directory

The program is installed on one domain computer or on a group of domain computers:

1. During Server Installation, install the Station Installer. If you did not install the Station Installer when installing the Application Server, install the Station Installer by selecting Control Panel⇒Add or Remove Programs⇒Change.
2. Select Start⇒Control Panel⇒Administrative and then select the Active Directory Users and Computers item.
3. Right-click the site, domain, or another organized unit that contains the computer or group of computers onto which ABBYY FlexiCapture 11 is to be installed.

4. On the shortcut menu, select Properties and click the Group Policy tab:
5. Click **New**, enter a descriptive name, and click **OK**.
6. Right-click the Group Policy Object you have created and select **Edit...**
8. On the shortcut menu, select **New/Package**.
9. Provide the path to the file ABBYY FlexiCapture 11 Stations.msi, which is located in the administrative installation folder on the server.

10. Select the Advanced deployment method.

11. In the dialog box that opens, click the Modifications tab and then click the Add button.

12. Select the interface language to be used in ABBYY FlexiCapture 11. The language files are located in the administrative installation folder on the server.

   The list of available files and their corresponding languages:
   - 1033.mst   English
   - 1049.mst   Russian

**Using SMS**

Microsoft Systems Management Server automates software deployment and eliminates the need to go directly to the locations where the software is to be installed (computers, groups, or servers).

SMS deployment includes the following three stages:

1. Creating an ABBYY FlexiCapture deployment package.
2. Creating a deployment script (contains installation parameters: names of computers, time of installation, conditions for installation, etc.).
3. Deployment of the program on the workstations by SMS based on the script settings.

Example: Deploying ABBYY FlexiCapture using Microsoft SMS

1. When installing the Application Server, create an installation package for ABBYY FlexiCapture stations.
2. In the SMS Administrator console, select the Packages node.
3. In the Action menu, select New Package.
4. In the Package Properties dialog box, fill out the required fields.
5. Click the **Data Source** tab.

6. Make sure that **This package contains source files** is cleared and click **OK**.

7. Expand the node of the newly created package and select **Programs**.

8. In the **Action** menu, select **New/Program**.
9. In the **Program Properties** dialog box, click the **General** tab and on this tab:
   - In the **Name** field, type a descriptive name of the program
   - In the **Command Line** field, type `setup.exe /q`
   - In the **Start in** field, provide the network path to the ABBYY FlexiCapture administrative installation folder (e.g. `\MyFileServer\Programs Dists\ABBYY FlexiCapture 11`).

10. In the **Program Properties** dialog box, click the **Environment** tab and on this tab:
   - Clear the **User input required** option
   - Select the **Runs with administrative rights** option
   - Make sure that the **Run with UNC name** option is selected

11. Adjust the running parameters if required and click **OK**.

12. You can also use the **Distribute Software Wizard**. In the **Action** menu of the package, select **Distributive Software** and follow the instructions of the wizard.
Important! You cannot create Distribution Points.

Installing Remote Stations
Using Remote Stations allows you to connect to the Licensing Server from the computers which are not part of the LAN. Remote Stations include the Data Verification and Scanning stations. The Verification station can be both regular and remote.
Remote Stations can connect to the Application Server via HTTP.
To install Remote Stations:

1. Select Distributed Installation.
2. Select a menu item corresponding to a station to be installed.
3. Select a setup language. The setup program will compare the locale of your system and the selected language. If the languages are incompatible, a warning message is displayed.
4. Next, the setup program checks the version of your operating system and the availability of the administrative permissions. If the version of the operating system is not supported by the program or you do not have the administrative permissions, a warning message is displayed and the setup program is terminated.
5. If all the checks are passed successfully, the end-user license agreement will be displayed. Read the license agreement carefully and if you agree with the terms of the agreement, select the corresponding option and click Next.
6. A dialog box will open prompting you to enter some information about yourself. Enter the required information and continue with the installation.
7. Next, select a destination folder. By default, the program is installed to: %systemdrive%\Program Files\ABBYY FlexiCapture 11 <Station>. If there is not enough space on the selected hard disk, a window is displayed showing your hard disks, the available free space, and the space required by the installation. Select a disk with sufficient free space and continue with the installation.
8. The program files will be copied onto your computer. Once the installation is finished, the setup program will display a message saying that the installation has completed successfully.

IMPORTANT!
1. The Application Server should be published to the Internet if you wish to use the remote stations over the Internet.
2. The Processing Server should be started to use remote stations.
3. Basic-authentication should be enabled in IIS in the Default Web Site\FlexiCapture11\Server folder to use such authentication type when connect to the Application Server.

Upgrading from ABBYY FlexiCapture 9.0 and 10

ABBYY FlexiCapture 11 can be installed on the same computer where ABBYY FlexiCapture 10 or 9 is already installed, but versions 10 and 9 cannot be updated to version 11.

You cannot use your ABBYY FlexiCapture 9 and 10 serial numbers to run ABBYY FlexiCapture 11.

You can use ABBYY FlexiCapture and ABBYY FlexiLayout projects and FlexiLayouts created in earlier versions of the program. When you open an ABBYY FlexiCapture and ABBYY FlexiLayout project created in an earlier version of the program, it will be converted to the ABBYY FlexiCapture 11 format. Once a project is converted, it can no longer be opened in the earlier versions.

If you have documents already loaded into the system, we recommend that you first complete the processing of these documents and only then migrate to ABBYY FlexiCapture 11.

Upgrading projects created in a standalone edition of ABBYY FlexiCapture (*.fcproj)

Projects created in a standalone edition of ABBYY FlexiCapture are stored in the file system. You can open projects created in ABBYY FlexiCapture 9.0 or 10 (.fcproj) and use them in ABBYY FlexiCapture 11. Please note the following:

- After you open an .fcproj in ABBYY FlexiCapture 11, you will no longer be able to open it in ABBYY FlexiCapture 9.0 or 10. If you think you will need to open an .fcproj in ABBYY FlexiCapture 9.0 or 10 in the future, create a copy of that project before opening it in ABBYY FlexiCapture 11.

- Once a project is updated, the Document Definitions lose their “published” status. To publish the Document Definitions, on the Administrator Station, select Project -> Document Definitions, then select the Document Definitions to publish and click Publish.

- When you open an ABBYY FlexiCapture 9.0 or 10 project in ABBYY FlexiCapture 11, you may need to delete all the processing results and analyze all the pages once again. (You may continue using old projects without recognizing the documents again, but some data may be displayed incorrectly. For instance, if there are format errors in an ABBYY FlexiCapture 9.0 or 10 project, they will not be displayed in the document window in the same way as such errors are displayed in ABBYY FlexiCapture 11.)

Upgrading projects and databases created in a distributed edition of ABBYY FlexiCapture

A distributed edition of ABBYY FlexiCapture works with projects that are stored in the database on the Application Server.

There are several ways to migrate from an earlier version to ABBYY FlexiCapture 11.

Connecting to a database created in an earlier version of ABBYY FlexiCapture

Once ABBYY FlexiCapture 11 servers are installed, you can use the Administration and Monitoring Console to connect to the database and file storage location that were used by your earlier version of ABBYY FlexiCapture. Then update the database to the new version and continue working with it. If you choose this method, you will no longer be able to work with your earlier version of ABBYY FlexiCapture.

Note: After you complete the steps described in this section, you will no longer be able to use your earlier version of ABBYY FlexiCapture. For this reason, we recommend that you back up your old database and file storage location before you processed with these steps. You can then use these back-up copies to restore the operation of your earlier version of ABBYY FlexiCapture if any problems occur. To back up your old database, use the back-up tools available in MS SQL or Oracle (depending on the type of DBMS that you use). Then copy all of the contents of the file storage location to a secure location. For detailed instructions on how to create a back-up copy, see the System Administrator’s Guide of your earlier version of ABBYY FlexiCapture.

To connect to the old database:

1. Complete the processing of documents with your earlier version of ABBYY FlexiCapture.
   - Complete the processing of all the batches that have already been registered in the system.
   - Start the Administration and Monitoring Console.
   - In the Administration and Monitoring Console, select Service -> Cleanup to remove any redundant data.
Select Monitoring -> Sessions to make sure there are no open sessions. If you see any open sessions, close the clients where this sessions are running.

Note: If, for some reason, you cannot close all of the clients with open sessions, disconnect the Application Server from the database. To achieve this, clear the value of HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture9.0 (or 10.0)\WebServices “DBConnectionString” in the Windows registry and restart the World Wide Web Publishing Service in the services.msc snap-in. Once you complete this step, you will no longer be able to use your earlier version of ABBYY FlexiCapture.

2. Connect to the database of your earlier version of ABBYY FlexiCapture.
   - Start the Administration and Monitoring Console of ABBYY FlexiCapture 11, select Service -> Application server, and click the Connect to existing database button.
   - Specify the name of the database server, the name of the database, and the path to the file storage location which were used by your earlier version of ABBYY FlexiCapture and click OK.
   - See Connecting to an existing database for more information about connecting to an existing database.

3. Update the database to the version used by ABBYY FlexiCapture 11.
   - After you connect to the database of your earlier version of ABBYY FlexiCapture, you will see an Upgrade link next to the name of the database on the page Service -> Application server. Click this link. The database will be updated to the version used by ABBYY FlexiCapture 11. Once you complete this step, you will no longer be able to use the database in earlier versions of ABBYY FlexiCapture.

4. Update the projects on the Application Server of ABBYY FlexiCapture 11.
   - Start the Project Setup Station of ABBYY FlexiCapture 11 and open all of the projects on the Application Server, one by one. When you open an old project, it will be updated to the version used by ABBYY FlexiCapture 11. Note that once a project is updated, the Document Definitions lose their “published” status. To publish the Document Definitions, on the Project Setup Station, select Project -> Document Definitions…, then select the Document Definitions to publish and click Publish.

Moving projects created in an earlier version of ABBYY FlexiCapture to a new database

If you wish to keep your earlier version of ABBYY FlexiCapture and at the same time use its projects in ABBYY FlexiCapture 11, you need to create a new database in ABBYY FlexiCapture 11 and move the required projects to this database. Note that this method will not move your documents.

Proceed as follows:

1. Export the projects created in your earlier version of ABBYY FlexiCapture from the Application Server to the file system.
   - On the Project Setup Station of your earlier version of ABBYY FlexiCapture, open the projects on the Application Server, one by one, and use the Project > Export Project command in the main menu to export the projects to the file system. This will only export the projects, the documents will not be exported. Therefore, be sure to complete the processing of the documents in your earlier version of ABBYY FlexiCapture;

2. Create a new database in ABBYY FlexiCapture 11.
   - In the Administration and Monitoring Console of ABBYY FlexiCapture 11, create a new database and specify the path to the new file storage location (see Creating a database for detailed instructions);

3. Update the projects to the version used by ABBYY FlexiCapture 11 and upload them onto the Application Server.
   - On the Project Setup Station of ABBYY FlexiCapture 11, open the exported *.fcproj projects, one by one. When you open an old project, it will be updated to the version used by ABBYY FlexiCapture 11. Note that once a project is updated, the Document Definitions lose their “published” status. To publish the Document Definitions, on the Project Setup Station, select Project -> Document Definitions…, then select the Document Definitions to publish and click Publish.
   - Once a project has been updated, upload it onto the Application Server by selecting File -> Upload Project to Server in the main menu of the Project Setup Station.
   - See Uploading a project to the server for more information about uploading projects onto the server.
Using ABBYY FlexiLayout Studio 9.0 or 10 projects (*.fsp)
All FlexiLayout Studio 9.0 or 10 projects can be opened in FlexiLayout Studio 11. Please note the following:
- It is impossible to open an .fsp-project in ABBYY FlexiLayout Studio 9.0 or 10 once it was opened in ABBYY FlexiLayout Studio 11, so you should create a copy of the project before opening it in ABBYY FlexiLayout Studio 11 if you still need to open it in ABBYY FlexiLayout Studio 9.0 or 10.
- After opening a FlexiLayout Studio 9.0 or 10 project in ABBYY FlexiLayout Studio 11 you may need to delete all processing results and analyze all pages once again.
- Due to changes in FlexiLayout language some compilation errors may occur. In this case you will need to correct errors and re-compile FlexiLayouts.

Using FlexiLayouts (*.afl) created in ABBYY FlexiLayout 9.0 or 10
FlexiLayouts compiled in ABBYY FlexiLayout 9.0 or 10 can be loaded into ABBYY FlexiCapture 11.
Sometimes due to changes in FlexiLayout language some compilation errors may occur. In this case open the *.fsp project in ABBYY FlexiLayout Studio 11, correct the errors and re-compile FlexiLayouts.
Managing Your Licenses

After you install the program, you need to activate your serial number. This section describes the use of ABBYY FlexiCapture 11 License Manager, the license management utility supplied with ABBYY FlexiCapture 11.

Overview

**ABBYY FlexiCapture 11 License Manager** is a license management utility. It is installed on the Licensing Server when the server are installed.

The License Manager allows you to:

- add new licenses
- activate licenses
- view license parameters
- select and enable licenses

Hardware licenses are activated in the same way as software licenses.

**ABBYY FlexiCapture 11 License Manager**

The main License Manager window contains the following columns:

- **Licenses** – displays the list of the installed licenses
- **License parameters** – displays the parameters of the selected license

License properties

- **General** – the serial number, expiration date, licensing method, ability to use a virtual machine
- **License purpose** – type of license (software or hardware), ability to provide document processing services
- **Work stations, Tools** – restrictions on the number of stations in the system and the use of development tools (FlexiLayout Studio, FormDesigner).
- **Productivity** – restrictions on the use of ABBYY FlexiCapture 11.
- **Processing** – additional document processing parameters: use of FlexiLayouts, use of additional recognition languages
- **Custom components** – use of components created by users
- **Import** – additional import capabilities
- **Export** – additional document and image export capabilities

**License statuses**
- **Activated** (the license had been activated)
- **Expired** (the license had expired or the page limit has been reached)

The current (i.e. active) license has a ✓ next to it and is highlighted in bold.

**Buttons**
- **Hide License Parameters<< (License Parameters>>)** – hides (shows) the detailed information about the selected license
- **Activate License...** - launches the ABBYY FlexiCapture Activation Wizard
- **Update License...** - refreshes the information about the activated license
- **Select** - makes the selected license current (i.e. active)
- **Refresh** – refreshes the information about the licenses available on the Licensing Server
- **Close** - closes the Licenses manager

**Activating a license**

ABBYY takes steps to protect its intellectual property from piracy. Software piracy is harmful both to manufacturers and to end users alike. Unlike legally purchased software products, pirated software is never safe and secure. If your end-user license agreement allows you to install and use the product only one computer, installing it on several computers will breach the agreement and violate the copyright laws of the Russian Federation. The activation technology restricts the number of software copies that can be used simultaneously and thus prevents the installation of one licensed copy on an unlimited number of computers. At the same time, one licensed copy may be installed and activated on one and the same computer any number of times without any restrictions. You will not be able to use the software product unless you activate it.

**How is activation carried out?**
The activation process takes very little time and is carried out via an **activation wizard**. The activation wizard helps you to send the data required for activation to ABBYY. These activation data are sent to ABBYY in the form of a code (Product ID) which is generated based on the hardware on which the product is installed. **No personal data are used** to generate the code and the user remains completely anonymous.

The following activation methods are available:
- **via Internet** - activation is carried out automatically and takes several seconds to complete; this method requires an active Internet connection
- **by e-mail** - an e-mail message is generated that contains the data required for activation; please do not alter the body or the subject of the message to ensure a prompt reply from the mail robot
- **by e-mail from another computer** – an e-mail message is generated that contains the data required for activation; you can use this method if the Licensing Server is not connected to the Internet and e-mail messages cannot be sent from it
- **load activation file** – connect an activation file you received by e-mail in response to an activation request

Once the activation is complete, ABBYY FlexiCapture 11 can be used on the server on which it was activated.
You can re-install ABBYY FlexiCapture 11 as many times as you need without additional activations (provided the Licensing Server is not re-installed).

Note:

1. **ABBYY FlexiCapture** stations automatically connect to the Licensing Server and use the installed license.
2. If you re-install the Licensing Server on a different computer, you will need to re-activate your licenses (in the case of a license file) and change the address of the Licensing Server in the LicensingSettings.xml file on the stations (see the Connecting stations to the Licensing Server section for details).
3. If there are no free activated licenses available on the Licensing Server and a user tries to run the program on their workstation, the program will not start and a warning message will be displayed.
4. Hardware licenses can only be activated over the Internet.

**Connecting stations to the Licensing Server**

All the stations installed in the system access the Licensing Server. The address of the Licensing Server is stored in the LicensingSettings.xml file, which can be found in the installation folder.

The address of the server is specified in the ServerAddress tag of the MainNetworkLicenseServer attribute.

To enable a station to access a new Licensing Server, simply change the old name to the name of the computer where the Licensing Server is installed.

The same applies to the standalone version of ABBYY FlexiCapture 11. If you have one license and several operator stations, specify the address of the computer where the license is stored in the LicensingSettings.xml files on the workstations.

Remote stations get licenses from the Application Server. The Processing Server connected to the Application Server must be running for you to get a license.
Quick setup of ABBYY FlexiCapture for demonstration installations

This paragraph briefly describes a fast minimal set-up of ABBYY FlexiCapture which can be used for demonstration installations. If you need a more detailed understanding of the ABBYY FlexiCapture settings, or if you need to perform the installation other than the default or more performance-oriented, or if you encounter any difficulties following the instructions of this paragraph, please go to the section "Detailed setup of FlexiCapture."

Before you begin, make sure that all FlexiCapture servers are installed on your computer and the set of installed features conforms to the default set in the Custom Setup dialog box of the program installer. FlexiCapture stations can be installed either on your computer or on any other computer that is accessible over the LAN. An MS SQL database server must also be available (you can install the MS SQL 2005 Express database server by running the Autorun.exe file from the FlexiCapture installation folder).

1. Open the Administration and Monitoring Console (select Start -> ABBYY FlexiCapture 11 Servers -> Administration and Monitoring Console or type the following link into the browser: http://<server name>/FlexiCapture11Monitoring/DBConnection.aspx) and go to the page Service -> Application server. On this page, create a new database. For this, click the Create New Database button and in the form that opens specify the following settings:
   a. Database server name, for example <computer name>\sqlExpress
   b. Database name, for example FCDemoDataBase

   Click OK.

   Once the database is created, you become the administrator of this database.

2. Upload a project to the server. For this:
   a. Run the Project Setup Station (select Start -> ABBYY FlexiCapture 11 Stations -> Project Setup Station)
   b. Open a local project (select File -> Open Project). You can choose a project from the samples located in the folder %public%\ABBYY\FlexiCapture (or %allusersprofile%\ABBYY\FlexiCapture for Windows XP/2003)
   c. Upload the project to the Application Server by selecting File -> Upload Project to Server. The address of the Application Server must be specified in the following format: http://<server name> (if the Project Setup Station and the Application Server are located on the same computer, the server address is as follows: http://localhost)

3. Configure the Processing Server. For this:
   a. Open the Processing Server Monitor (select Start -> ABBYY FlexiCapture 11 Servers -> Processing Server). Make sure that the Processing Server is started.
   b. Add Processing Stations. For this, choose the Stations item from the ABBYY FlexiCapture 11 Servers -> <Server Name> tree, then select the Add Stations command from the Actions menu. In the dialog box that opens, click Custom and enter the name of the computer where the Processing Stations are installed (for example, localhost), or click Browse and choose desired computers.
   c. If images from Hot Folders are to be imported in the project, the processing of Hot Folders must be enabled in the Processing Server. For this, from the ABBYY FlexiCapture 11 Servers -> <Server Name> tree, choose the Hot Folders item; the project name will appear to the right. Choose the project from the list and from the Actions menu select Enable.

Detailed setup of ABBYY FlexiCapture

How to choose the user authentication type

All components and users of ABBYY FlexiCapture 11 Distributed interact with the Application Server and must be authenticated on the computer where it is installed. ABBYY FlexiCapture supports two types of user authentication:
1. **Standard IIS authentication.** Users are authenticated with their Windows accounts using Windows or Basic authentication in IIS. Then users' identification in ABBYY FlexiCapture is performed according to their logins. This method requires minimal configuration and is suitable for scenarios where all FlexiCapture components and users are in the same domain.

   If the whole system or some of its components are outside of the domain, then a pass-through authentication should be used for the standard IIS authentication. The general principle of the pass-through authentication is as follows: for the user of the computer M2 working under the local account M2\User\[password] to be authorized on the computer M1, this account should be duplicated on the computer M1 down to the password (that is, M1\User\[password] should be created).

   **Example of using pass-through authentication**

   Suppose the Processing Station is installed on the computer M1 which is not included in the domain of the Application Server. In this case, a local user M2\User\[password] must be created on the computer M2 where the Application Server is installed and the same local user must be created on the computer M1: M1\User\[password]. Then the service of the Processing Station must be started under the M1\User\[password] account. Now the Processing Station can be authenticated on the computer where the Application Server is installed.

   **Note:** If the Application Server is installed outside the domain, the setup may be time-consuming. You will need to start the IIS pools and the services of the Application Server and the Processing Stations under specially created local Windows accounts and configure pass-through authentication for these users on all computers of the system.

2. **Authentication by means of ABBYY FlexiCapture.** In this case, the FlexiCapture Authentication Module is installed in IIS. This module performs user authentication based on information which is stored in a FlexiCapture database. This allows you to use user accounts which are not related to Windows user accounts.

   This method is convenient for users located outside the domain where the Application Server is installed, e.g. for operators who work remotely over a Web-based interface.

   If this authentication method is used, a Web-based interface for login to the system (http://<server name>/login) is also installed. This is a single entry point for Web operators which new operators can use to self-register in the system and request access rights to stations.

   Users of interactive processing stages (e.g. scanning, verification, etc.) can use both types of authentication. The Processing Server and Processing Stations can work only with standard IIS authentication.

   **Note:** In IIS, requests to the Application Server are processed by the <Default Site>\FlexiCapture11\Server\WebServices.dll library, which is available both with Windows and Basic authentication. During the installation of the FlexiCapture Authentication Module, the <Default Site>\FlexiCapture11\Server\WebServicesExternal.dll is also installed. This library is a copy of WebServices.dll, but it is available when using ABBYY FlexiCapture authentication. Thus, the Application Server is available to all system components at the same time both with standard authentication and with FlexiCapture authentication. When the user on whose computer the stations are installed tries to open a project, he is prompted to choose which authentication to use to access the Application Server. Web-clients can also work with both authentication types; the type being used is determined by using the key UseCustomAuthentication in the file web.config on each Web station: if the key is set to true, authentication is performed by means of ABBYY FlexiCapture, if the key is set to false, standard means of authentication is used. By default, the key is set to false if the FlexiCapture Authentication Module is not installed, otherwise the key is set to true.

   To use only standard IIS authentication (the first method), the Authentication Module feature must be disabled during the installation of FlexiCapture servers (the feature is disabled by default). To use ABBYY FlexiCapture authentication (the second method), this feature must be selected when installing servers, or you can install it later via the Control Panel (select Control Panel -> Program and Features -> Modify).

**Creating a database**

After you install the program and activate the license, it is necessary to configure the system. The first step is to create a database.

**Important!** Under Windows Vista, Windows 2008 or later versions of the Windows operating system, a database must be created with UAC disabled. If UAC is not disabled, a database can be created, but the Application Server will not be able to connect to it.
1. On the computer where the Application Server is installed, open the Service -> Application Server page of the Administration and Monitoring Console (http://<server name>/FlexiCapture11/DBConnection.aspx) under a user account with Windows administrator privileges.

2. Click the Create New Database button.

   Note: If you are already connected to another database, you will need to close the existing sessions prior to creating a new database. If, for some reason, this is not possible, add the following key in the web.config file which is located at <IIS Root Directory (by default "C:\inetpub\wwwroot")>\FlexiCapture11>:

   - <appSettings>
     - <add key="IgnoreCurrentSessions" value="true"/>
   - </appSettings>

   In this case, a new database will be created without a warning about existing sessions. In the old database, all sessions are preserved. By default, the key is set to false, which means you will be prompted to close the sessions when recreating a database.

3. The database creation page will open.
On this page, specify the following:

a) Type of database server: Oracle or MS SQL
   
   **Note:** If you plan to use an Oracle database server, you must configure it before creating a database (see Oracle database settings).

b) Name of new database (if MS SQL Server is selected). Note the limitations imposed by MS SQL on database names (see http://msdn.microsoft.com/en-us/library/ms175874.aspx).

c) A user with DBA permissions on SQL or Oracle server.
   
   **Note:** If MS SQL Server is installed on a different computer than the Application Server, then Database Server Authentication must be used to connect to the database server.

   **Note:** If MS SQL Server is used, then we recommend choosing the TCP/IP protocol rather than Named Pipes to communicate with the database server (the protocol is specified when you configure MS SQL Server Client, which is installed on the computer hosting the Application Server).

d) Select the “Use external file storage” option and specify the path to the file storage location. The file storage location stores the images to be processed and metadata. The speed of communication between the Application Server and the file storage location greatly affects the performance of the entire system. Therefore, we recommend placing the file storage location in a folder that is local to the Application Server. To achieve maximum performance, we recommend placing the file storage location on the same physical drive as the IIS temporary folders. The drive itself must be a high-performance drive. You can also use a high-performance external device to store data (for more details, see Recommendations for setting up ABBYY FlexiCapture).

   **Note:** If no file storage location is used, all project files are stored in a database. For small amounts of processing, the two solutions are equivalent in terms of performance and security. Storing project files in a database makes backing up and restoring data easier, but for large amounts of processing, it increases the size of the database, which may decrease the system’s performance. Therefore, storing project files in a database is recommended only for demonstration projects.

   **Note:** A file storage folder must be excluded from the scope of anti-virus software and the Windows indexing service that enables fast searching.

e) Use the Test Connection button to check the entered values. If the test is successful, click OK.

To create a database, follow these steps:

1) If Database Server Authentication is used, the database is created on behalf of the user account specified on the Service -> Application Server page of the Administration and Monitoring Console. If Windows authentication is used, the database is created on behalf of the user account under which the browser with the Service -> Application Server page is started.

To create a database in MS SQL, the user must have the following permissions:
To connect to an existing database, do the following:

1. CREATE DATABASE, CREATE ANY DATABASE or ALTER ANY DATABASE to create a database
2. ALTER ANY LOGIN to create a new user
3. db_accessadmin and db_securityadmin rights to the new database to be able to provide db_owner rights to the user whose account the Application Server is running.

To create a database in Oracle, the user must have the roles CONNECT and DBA (for more details, see Oracle database settings).

On behalf of this user, first the Description.sql (or Description_Oracle.sql if Oracle is used) script and then the DBInitFill.sql (or DBInitFill_Oracle.sql if Oracle is used) script are executed. The scripts are located on the computer where the Application Server is installed at <IIS Root Directory> (by default "C:\inetpub\wwwroot")>\FlexiCapture11\Server. The first file is responsible for creating a database, while the second one is responsible for its contents. Files Upgrade*.sql located in the same folder are not used when creating a new database.

2) In the case of MS SQL, a new user account, under which the FlexiCapture 11 Web Services pool of the Application Server Web service is running, is added to the database server (by default, the pool of the Application Server is started under the user account Network Service).

3) db_owner rights to the FlexiCapture database created in step 1 are assigned to the new user account created in step 2 (if MS SQL is used). All further operations concerning server interaction with the database are performed on behalf of the user created in step 2. The account used for creating a database in step 1 can be deleted from the database server if necessary.

In the case of Oracle, all further work with the database during the operation of ABBYY FlexiCapture is performed under the account used for creating the database in step 1; no additional accounts are created (in contrast to MS SQL).

4. If you are using FlexiCapture authentication (for this, the Authentication Module must be installed), then, after creating a database, you will receive a message saying that a temporary password password has been created for your account.

To continue working with the system, it is necessary to change the password. For this, go to the login page (http://<server name>/FlexiCapture11/Login).

When trying to open any page of the Administration and Monitoring Console after creating a database, the user will be automatically redirected to the login page to change the password. Once the password is changed, the user will be returned to the page of the Administration and Monitoring Console.

5. The user who created the FlexiCapture database automatically gets administrative privileges for the system. The administrator also has the right to change the settings of the Application Server, upload projects to the Application Server, grant access rights for projects, create new users, and manage their roles and access rights.

The administrator of the system can grant the administrator role to another user and delegate further configuration of the system to that user. The user who created the database cannot be deprived of the administrator role, neither can that user’s account be deleted from the system.

Connecting to an existing database

Instead of creating a new database, you may need to connect to an existing database created in one of the previous releases of ABBYY FlexiCapture (see Upgrading from ABBYY FlexiCapture 9.0 and 10).

Important! Under Windows Vista, Windows 2008 or later versions of the Windows operating system, UAC must be disabled on the computer where the Application Server is installed before connecting to the database.

To connect to an existing database, do the following:

1. On the computer where the Application Server is installed, run the Administration and Monitoring Console under a user account with Windows administrator privileges and go to the page Service -> Application Server (http://<server name>/FlexiCapture11/Monitoring/DBConnection.aspx).

If the Application Server is already connected to a database, go to step 4.

2. Click Connect to Existing Database.

3. In the form that opens, fill in the following fields: type of database server, name of the existing database (if MS SQL Server is used), the user who is the administrator of the database server, path to the file storage location (if a file storage location is used). Click OK.

4. Now your server is connected to the database. If the Upgrade link is displayed on the Service -> Application Server page (http://<server name>/FlexiCapture11/Monitoring/DBConnection.aspx), next to the database version, then you should upgrade the database before you proceed.
5. If you have installed the Authentication Module and authentication by means of ABBYY FlexiCapture has not been used for this database before, a temporary password **password** is assigned to the user under whose account the Administration and Monitoring Console was started.

**Uploading a project to the server**

For ABBYY FlexiCapture Distributed operators to work on the same project(s) together, the project(s) must be uploaded to the Application Server. To upload a project to the server, the user must have the role of administrator of the system.

To upload a project to the server, open the Project Setup Station and do one of the following:

- Create a new project (select **File -> New project...**). Create or import at least one Document Definition (select **Project -> Document Definitions**).
- Open a sample project (sample projects are located at `%public%\ABBYY\FlexiCapture\11.0\Samples` for Microsoft Windows Vista and later versions or `%allusersprofile%\Application Data\ABBYY\FlexiCapture\11.0\Samples` for other version of Microsoft Windows).
- Open your own project created in an earlier version of ABBYY FlexiCapture. The project will be automatically converted to the format used by the new versions of ABBYY FlexiCapture. You will no longer be able to use this project in your earlier version of ABBYY FlexiCapture. Once a project is updated, the Document Definitions lose their “published” status. To publish the Document Definitions, on the Project Setup Station, select **Project -> Document Definitions**, then select the Document Definitions to publish and click **Publish**.
- Create a new project and import a batch created in FormReader 6.5 DE or EE.

It is essential the project should have at least one correct attached Document Definition for which export settings are specified.

Then upload the project to the Application Server (select **File -> Upload Project to Server...**).

**Note:** When uploading a local project to the Application Server, a new project similar to the local one is created on the server. A newly created project contains the same Document Definitions, batch types, import sources, and project settings. Working batches with images are not copied from a local project to the server. Test batches (they are created for a particular user) are available to the user both from the local and from the server project.

**Creating new users**

The way of creating new users varies depending on the authentication type which is supposed to be used for these users (see **How to choose the user authentication type**).

**Note:** If standard IIS authentication is used, ABBYY FlexiCapture requires only a user’s Windows login to authenticate the user. If authentication by means of FlexiCapture is used (the Authentication Module feature must be installed), the user password must be also stored in the system (the password hash is stored in the FlexiCapture database).

In general, login of the account that will be authenticated by means of FlexiCapture can be arbitrary; in particular, it may coincide with the user’s Windows login. In this case, the user will use the same login, but different passwords to access the system using different authentication types (for standard IIS authentication, the password specified in Windows is used; for authentication by means of FlexiCapture, the password specified in FlexiCapture is used). FlexiCapture identifies users by their logins, so in terms of FlexiCapture, it will be the same user regardless of the authentication method.

Thus, if FlexiCapture knows only a user’s login, the user can be authenticated by standard IIS authentication only. If a user password is specified in FlexiCapture, the user can be authenticated by means of the FlexiCapture Authentication Module. To enable authentication by means of FlexiCapture for a user, a temporary password can be created for this user account. For this, on the User Permissions page of the Administration and Monitoring Console, click **Reset Password**.

**Adding users manually**

To add users manually, the FlexiCapture administrator must do the following:

- Open the Administration and Monitoring Console, go to the **Permissions -> Users** page, and click **New User**.
- On the page that opens, specify the login of the new user and click **Save**.
- If the Authentication Module feature is installed, a message will be displayed saying that the user is assigned a temporary password **password**.

A user added in this way:
- can be authenticated using standard IIS authentication, if the user’s login in the system matches the user’s Windows login. In this case, the Windows password must be used for authentication. If the user is not in the domain where the Application Server is located, the pass-through authentication can be used.

- can be authenticated by means of the FlexiCapture Authentication Module, if that feature is installed. In this case, a login and a temporary password password specified by the administrator are used for authentication (the password must be changed at first logon to the Web station or on the page http://<servername>/FlexiCapture11/Login).

Importing users from Active Directory

This method of adding users is usually used when the system is installed in a domain and users of the system are employees of the organization whose accounts are stored in Active Directory.

To import users from Active Directory, the FlexiCapture administrator should open the Administration and Monitoring Console and on the Permissions -> Users page, click the Import button. Both individual users and existing user groups can be imported.

Users added in this way can be authenticated by IIS standard authentication using their Windows logins.

If the Authentication Module feature is installed and you want to enable user authentication by means of the FlexiCapture Authentication Module, go to the page where user permissions and roles are edited and set a temporary password for each user using the Reset Password button.

Note: If the Reset Password button is missing, it means that the user password has already been changed to a default password password.

Self-registration of users through the Web interface

This method of adding users applies when a large number of users are remote operators (e.g. working through a web-based interface) and do not belong to the domain where the Application Server is installed. To use this method, the Authentication Module feature must be installed.

To enable operators outside of the domain where the Application Server is installed to be authenticated on the Application Server, it is recommended to use FlexiCapture authentication. For this, the Authentication Module feature must be installed.

New users can self-register in the system through the Web interface following the Registration link on the http://<servername>/FlexiCapture11/Login page.

Note: For the Web application http://<servername>/FlexiCapture11/Login, anonymous authentication is enabled in IIS settings, so the registration page can be accessed by any user.

Registration

All the fields are mandatory for filling.

First and Last Name: 
Login: 
E-mail: 
Password: 
Repeat Password: 

Sign up  Cancel

Help  Technical Support  EULA

After filling out the registration form and clicking Sign up, the user will be added to the system and redirected to their personal page.
To create a request for access rights and roles, the user must click the **Create Request** link.

Requests for roles and access rights are processed by the administrator on the **Permissions -> Requests** page of the Administration and Monitoring Console.

Once the roles are assigned and access rights are granted to the user, the list of available stations will be displayed on the user's personal page. To update information on the personal page, click the **Refresh** button.

Thus, as soon as the administrator has processed the request and clicked **Complete**, the user can see on his personal page that the request has been processed.

### Self-registration of users (without using the Web interface)

This method of adding new users is suitable when standard IIS authentication is used and the FlexiCapture Authentication Module is not used. The described method allows the administrator to skip entering user logins manually. Instead the administrator has only to assign roles and grant access rights to n already created login.

With this registration method, a user can log into the station using a Windows login and attempt to open a project. An error message “Access denied. Contact your administrator” will be displayed. At the same time the user's login will be displayed on the **Permissions -> Users** page of the Administration and Monitoring Console, which will help avoid errors when typing user logins manually by the administrator and will reduce the administrator’s work to assigning roles and granting access rights to users.
Setting up user roles and access rights

To manage user roles and access rights, the administrator must go to the Permissions -> Users page of the Administration and Monitoring Console, find a desired user, and click the user’s login to open the link.

The administrator can assign roles to the user (e.g. scanning operator, verification operator, etc.) and grant access rights to projects and individual batch types within the assigned role. The roles of Administrator, Processing Server, and Monitoring Operator are assigned for all projects at once.

The role of the Processing Server should be assigned only to the user under whose account the Processing Server is running (see Configuring the Processing Server).

Note: For the role of Web Capture Operator, the list of projects and batch types can be displayed without the possibility to choose them. The reason is that within the given role, access rights can be granted only to the projects in which the "for Web Capture station" or "Advanced for Web Capture station" workflow scheme is used.

The Reset Password button is displayed only if the Authentication Module feature is installed. In this case, the button allows you to create a temporary password password for a user. In particular, this allows users added via Active Directory to get a temporary password in FlexiCapture and use it for authentication by means of FlexiCapture (see How to choose the user authentication type).

Note: If the FlexiCapture Authentication Module is installed and the Reset Password button is missing on the user’s page, it means that the password has already been changed to a temporary one.

Configuring the Processing Server

The Processing Server processes tasks of non-interactive (automatic) stages, for example, importing images from a Hot Folder, recognition, export, etc. The Processing Server contains a pool of Processing Stations which perform processing tasks.

Besides, the Processing Server ensures effective protection and licensing for remote and Web stations: for the stations to start, the Processing Server must also be started, otherwise a message saying that there is no license will be displayed when the station starts.

To start work:

1. Assign the role of Processing Server to the user under whose account the Processing Server is running.

   By default, the Processing Server is installed on the same computer as the Application Server and is started under the Network Service user account. In this case, the role is assigned to the Processing Server automatically and this step can be skipped.
Otherwise, you should grant access rights to the Processing Server on the Permissions -> Users page of the Administration and Monitoring Console.

If the Processing Server is installed on the computer other than the Application Server, but is started under the Network Service user account, the user will be displayed as <Domain>\<Machine Name>$ in the Administration and Monitoring Console. If the service of the Processing Server is started under a different user, it is necessary to assign the role to this user.

2. Start the Processing Server Monitor (select Start -> ABBYY FlexiCapture 11 Servers -> Processing Server) for further configuration.

3. In the Processing Server Monitor, select Actions -> Properties and in the dialog box that opens, specify the address of the Application Server (e.g. http://ApplicationServer). If the Processing Server and the Application Server are installed on the same computer, the address of the Application Server will be specified automatically.

4. Start the Processing Server using the button.

5. Add Processing Stations. For this, in the server tree, select Stations and click . In the dialog box that opens, select the stations based on the names of their computers or find them in the network:

   ![Processing Server Monitor - BEREZKINA](image)

   After adding a station, you specify its parameters in the Station Properties dialog box (select Actions -> Properties). The station is started automatically within a minute. If the station requires lengthy setup or you do not want to start the station, deselect the Start automatically option in the station properties.

   To start desired stations manually, select them from the list in the main window of the Processing Server Monitor and start them by clicking the button.

   **Note:** We do not recommended installing the Processing Station on the computer where FlexiCapture servers are installed as it reduces the performance of the server.

6. If in some projects you need to import images from a Hot Folder, enable Hot Folders in the Processing Server Monitor using the corresponding item in the server tree:
7. If necessary, in the Project Setup Station, specify processing settings for the project (the specified settings will apply to batches of the Default type). To configure processing settings, select **Project -> Project Properties...** and open the **Workflow** tab. If the project contains batch types, specify workflow settings for each of them. For this, select **Project -> Batch Types...**, then select a desired type, click **Edit...**, and in the dialog box that opens go to the **Workflow** tab.

**Oracle database settings**

Prior to creating a database in Oracle, do the following:

1. On the computer on which the Application Server is installed, install the Oracle client for Windows 32bit (even though Windows x64 is installed and Oracle DBMS for this OS). The Application Server does not work with the Oracle x64 client.  
   **Note.** The Oracle client may install incorrectly due to a known issue. This causes a “Description Provider cannot be found. It may not be properly installed” error to occur when creating a database. If you see this error message, you will need to register the oraoledb11.dll library manually by executing the “regsvr32 oraoledb11.dll” command. The oraoledb11.dll library is located in the BIN folder in the installation folder of the Oracle client.

2. If Windows x64 is installed, pools for the **Administration and Monitoring Console** and the Application Server must be set to 32-bit mode. For this, do the following:
   - Execute the following command from the command line: `cscript %systemdrive%\Inetpub\AdminScripts\adsutil.vbs set W3SVC/AppPools/Enable32BitAppOnWin64 true`
   This command switches the default pool to 32-bit mode, thus the default pool and the pools of the Administration and Monitoring Console run in the same mode which is required for registration of ASP.net. For this command to take effect, access to the Network Service account must be granted explicitly. To grant access to the Network Service account, execute the following command: `aspnet_regiis -ga "NT Authority\Network Service"`. 
3. In Oracle DBMS, create a user, e.g. FCUSER, and assign the CONNECT and DBA roles to this user. One FlexiCapture database corresponds to one user. If several FlexiCapture databases running under Oracle DBMS are required, create a user for each database.

**Note:** If, for security reasons, you do not want to have a user with the DBA role, then after creating the database you can revoke the DBA role from the user. The CONNECT role and the privileges for all objects of the user scheme must be preserved (they must be granted by default), and the privilege for TABLESPACE where the FlexiCapture database is located should be granted explicitly (ALTER USER user QUOTA unlimited ON tablespace;). It should be noted that with these settings, you will not be able to apply patches to your database via the Administration and Monitoring Console, but this is seldom required (patches are provided by ABBYY technical support in case of problems with the database). For the time the patch is applied, the user should be reassigned the DBA role.

The user must also have privileges for the standard dbms_lock batch. To grant these privileges to the user, run the following command as the database server administrator:

```
Grant Execute On dbms_lock To FCUSER;
```

where FCUSER is the name of the user you created for ABBYY FlexiCapture. It is assumed that when you run this command, no database has yet been created under this user's account in the Administration and Monitoring Console.

**Note:** If you have already created a database in the Administration and Monitoring Console using this user's account, you need to run the following additional commands:

```
Alter Procedure FCUSER.CleanUp_ELDayCleanUp Compile;
Wait for the command to complete and then run
Alter Procedure FCUSER.CleanUp_StartCleanUpJob Compile;
```

where FCUSER is the name of the user you created for ABBYY FlexiCapture.

4. Establish the connection between the client and the Oracle server using the Net Manager utility, which is installed together with the Oracle client (in the Administration configuration) and the database server. In the client utility, create a new Service Naming element (a local naming method), which must be connected with the Oracle database server by its SID. Test the connection with the database server on behalf of the user account created in step 2. Go to the next stop only if the connection test succeeds. If you cannot set up the connection, consult the Oracle documentation.
5. When creating the database in the Administration and Monitoring Console, specify the name of the Service Naming element created in step 3.

After you create the database using the Administration and Monitoring Console you should note that by default, an Oracle database allows a maximum of 40 processes and 49 sessions. When these limits are reached, the following error message occurs: “ORA-12516: TNS:listener could not find available handler with matching protocol stack.”

If required, increase the default values by using a script similar to the following:

```sql
connect sys/<Login> as sysdba;
alter system set sessions=<SessionCount> scope=spfile;
alter system set processes=<ProcessCount> scope=spfile;
shutdown immediate;
startup;
```

Web stations’ settings

Web stations are installed together with the Application Server, if the Web stations feature is selected in the Custom Setup dialog box.

Description of possible Web stations settings

For each Web station located at <IIS Root Directory (e.g. C:\inetpub\wwwroot)>\<Station Name>, there is a web.config configuration file, whose section <appSettings> contains the following keys that define the behavior of the station:

**ApplicationServer** – the address of the Application Server in the format <machine name>, without “http://,” has a default value of “localhost.” The key allows you to move the Web station to a different computer than the one where the Application Server is installed, e.g. in DMZ network.

**DefaultDomain** – this key stores the name of the domain which will be added to the names of users who try to log into the station. By default, the value is empty. It means that the user <domain>\user must enter the whole login: <domain>\user to log into the station. If the key has the value “domain,” the domain name can be omitted and the shortened login “user” can be used. If the user belongs to a different domain or is a local user, it is possible to specify the whole login in the format “machine\user.” In this case, the value of the DefaultDomain key will not cause conflicts.

**UseCustomAuthentication** – this key allows you to switch the authentication mode used by the station: either standard IIS authentication or authentication by means of the FlexiCapture Authentication Module can be used (see “How to choose the user authentication type”). If the FlexiCapture Authentication Module is installed, the server installer sets the key value to **true**, otherwise – to **false**.

**UseHashedPageAccess** – this key determines whether automatic log off is performed when closing the browser window or a separate browser tab. If the key value is **false**, log off is performed only when closing the browser window. If you close the browser tab when working with the station without doing the log off, but the browser itself remains open, you will be able to open the station in a new tab and continue working with it without entering a login and password. If the key is set to **true**, automatic logoff is performed also when closing a separate browser tab. In this case, when you open the station in a new tab, you will have to enter your login and password. Automatic logoff is performed also when refreshing any station page (using the **Refresh** command or the F5 key). This key can be used only for the Web Scanning and Web Capture stations. By default, the key is set to **false**.

**UseCustomFormLayout** – this property determines how the data form is displayed. If set to **true**, the custom data form is displayed. If set to **false**, the default data form is displayed.

**PluginMode**

Set this subkey to **WithoutScanning** to redirect web station users to the image import page without installing the ABBYY Scanning Plugin. If the value of this key is set to **Full**, the Plugin will be installed when a project is opened for the first time.

This subkey only affects Web Scanning Stations and Web Capture Stations. Its default value is **Full**.

**ShowPluginModeSwitch**

Determines whether the station works with or without the plugin. If set to **true**, a drop-down list that allows the user to choose whether to use the plugin will be displayed on the project selection page.

This subkey only affects Web Scanning Stations and Web Capture Stations. Its default value is **false**.
Security settings in ABBYY FlexiCapture Distributed

For user authentication, either Windows or Basic authentication or authentication by means of the FlexiCapture Authentication Module can be used.

Windows authentication is more secure (login and password are not transmitted over the network in clear text), but this authentication method is convenient only within a domain.

Basic authentication and FlexiCapture authentication can work outside the domain as well, so these authentication types must be used for distributed work. The main disadvantage of these authentication types is that user identification information (login and password) are transmitted on each request to the server. Therefore, in the case of Basic authentication (or authentication by means of FlexiCapture, which uses the same protocol), SSL encryption (https) must be used. Using SSL encryption prevents reading or modifying data sent between client and server.

Client applications working on Basic-authentication or authentication by means of FlexiCapture Authentication Module have to store the user name and password in a cookie to be able to pass them each time the server is accessed. In this case, security is ensured by the fact that these data do not get to the drive or a client machine. If a user specifies the name/password when first accessing the server, between requests these data are stored in the application memory and are deleted at log off or when closing the browser, so they do not pose a threat to security.

To get the Application Server work over the https protocol, the IIS certificate must be installed on the Application Server:

Working over https

To ensure safety, you can use https protocol. For this, you need to enable SSL support in IIS settings.

To work with IIS over HTTPS protocol, you need to obtain a certificate for the server and connect it.

Managing certificates


Connecting certificate in IIS on Windows 7

In IIS settings, connect HTTPS protocol for Default Web Site. For this:

1. Run IIS Manager Console from the Control Panel.
2. Choose Default Web Site and on the Actions panel, click the Bindings link.
3. In the dialog box that opens click Add and select “https” protocol from the “Type” drop-down list.
4. From the “SSL Certificate” drop-down list, select a desired certificate and click Ok.

© 2014 ABBYY Production LLC. All rights reserved.
5. If you want the site to be available via https only, then choose it in the tree of sites, open SSL Settings and select the option “Require SSL.”

**Note:** Verification of client certificates is not performed, so when configuring SSL, set the value of the “Client certificates” option to **Ignore**.

Once the certificate is connected, the “https” protocol must be written in the address of the Application Server and the computer name must match the name for which the certificate is issued: https://<server name>.

This is required in the following cases:
1) When specifying the address of the Application Server on the Processing Server. To specify the address, do the following:
   - start the Processing Server Monitor;
   - in the Processing Server local menu, select the “Change Application Server” item;
   - in the dialog that opens, specify the address: https://<server name>.
2) When working on user stations, the server address https://<server name> must be specified when you start the station or open a project
3) Similarly, when working on Web stations, the station URL must be entered starting from the server address: https://<server name>/FlexiCapture11/<Web station name>

**Recommendations for setting up ABBYY FlexiCapture**

**General recommendation**
To improve performance of ABBYY FlexiCapture, use the following recommendations:
- Install SQL Server and FlexiCapture Application Server on different computers. The Processing and Licensing servers can be installed on the computer where the Application Server is installed.
- Do not install processing stations on the computers where FlexiCapture servers or SQL Server are installed.
- Do not store all data in SQL database. For these purposes, a File Storage should be used. This option must be selected when creating a database in the Administration and Monitoring Console. If a file storage was not created when creating a database, it cannot be connected later while working. During work, it is also impossible to disconnect the file storage which was connected when creating the database.

These recommendations are described in more detail below.

**Configuring SQL Server**

**RAM**
The amount of RAM available to SQL Server should be not less than the amount recommended by Microsoft for the given edition of MS SQL Server (see the table of recommendations for different editions). The more RAM is available, the larger part of database can fit in RAM which allows faster access to database.

However, if FlexiCapture servers are installed on the same computer, the amount of RAM available to SQL Server must be restricted in SQL Server settings so that the amount of RAM was also sufficient for FlexiCapture servers including IIS (recommended amount of RAM is at least 4 GB). Thus, in order to improve performance, it is recommended that SQL Server and FlexiCapture Servers should be installed on different computers.

**Hard disk**
It is desirable to place the database file on a fast hard drive (e.g., 15000 rpm/second). If MS SQL Server is installed on the same computer with FlexiCapture Servers, it is desirable to use one hard disk for the %temp% folder of IIS and the File Storage and another disk – for SQL database.

**Database File**

The process of increasing the database file may lead to a temporary decrease in SQL Server performance, so it is recommended to specify in database properties in Autogrowth settings that a one-time increment of the database file must be at least 100 MB.

**Recovery model**

To improve performance of SQL Server, it is desirable to use a Simple Recovery Mode for the database.

**Rebuilding indexes**

After long work of FlexiCapture, a significant increase in the size of database can be noticed. At the same time, more than 50% of the space can be occupied not with data, but with the indexes in tables.

In order to decrease the size of database and improve performance, it is recommended that indexes should be rebuilt periodically (e.g., once for every million pages processed). This operation should be performed on tables, which contain data to be changed frequently. It is recommended to perform this operation or a regular bases for the Batch, Document, Page, EventLog, Task, DocumentParameter and BatchParameter tables.

**Estimating the size of File Storage**

Most of the space in file storage is occupied by images being processed in the system. For each loaded file, its source image is stored as the original; besides black-and-white image copies and image thumbnails are created. For color images, color copies with quality loss are also created.

The level of quality loss is specified in batch type properties, in the **Displayed image quality** field.

To get a relatively accurate estimate of the file storage size, you can upload 10 typical images to FlexiCapture and view the size of a file storage folder, in which the batch (&lt;FileStorage&gt;&lt;GUID&gt;&lt;project_id&gt;0000-0999&lt;Batch Id&gt;) is stored.
Estimates for the file storage obtained during testing are as follows: for 1 image, 3-6 times more space in the file storage than the image size is needed.

**File Storage**
For the file storage, it is recommended to use a disk that is local relative to the Application Server (or a system of comparable performance). To achieve maximum performance, it is recommended that the %temp% for IIS should be located on the same physical disk as the File Storage.

In order to increase performance, it is recommended that a file storage folder should be excluded from the scope of anti-virus software, Window indexing service and other processes that require long-term access to the disk. Preferably use a faster hard drive (e.g., 15 000 rpm/second).

**Application Server**

**Caching**
In order to decrease the amount of memory occupied by IIS, it is necessary to disable Output in the IIS settings. Using the cache does not lead to increasing performance, as the identical information is not frequently requested by FlexiCapture.

**Hard disk**
IIS uses the hard disk intensively as all files transmitted through it are saved to the disk. System environment variables TEMP/TMP are used by IIS as a directory for temporary files. By default they point to a folder on the system drive.

To achieve maximum performance, it is recommended to use a fast hard drive (e.g. 15 000 rpm/second) for storing the TEMP/TMP folders.

Overriding the variables TEMP/TMP to a disk other than the system drive can lead to a significant decrease in performance, so the system drive must be fast.

**Configuring settings of the Application Server Recycling Pool**
For FlexiCapture 11 Web Services, the Application Server pool, it is necessary to specify Recycling settings, that is to enable cleanup of the pool when it reaches a certain threshold of consumed memory. The threshold is determined based on the amount of available memory in the system: when IIS consumes maximum memory, there must remain enough memory for normal functioning of the operating system and other applications that can be installed on the same computer.

It is recommended to set up a forced cleanup of the Application Server pool when the amount of occupied memory reaches 1200000 KB.

**Number of threads**
For the Application Server pool, the number of working processes can be specified. The optimal number of threads is two threads per processor core if hyper-threading technology is not used on the computer and one thread per virtual core if hyper-threading is used.
Configuring FlexiCapture input and output

Frequently, the bottleneck that limits performance of the system is the input (import) or the output (export). Below are the two ways to increase performance in bottlenecks of FlexiCapture:

1. If it is assumed that a large number of Processing Stations will simultaneously import files from a hot folder or export files to file system, then the hot folder and/or the export target must be located on the computer with the server edition of the operating system. Normally, client operating systems support a limited number of connections which may lead to error in import/export tasks.

2. If a hot folder is assumed to be processed at several Processing Stations, then bandwidth to the hot folder will be divided between the Processing Stations which may lead to bandwidth shortage. In this case, it is recommended to use multiple independent hot folders. If export to files is performed, it is recommended that export target should not be on the same computer with the hot folders

Using performance counters

To monitor FlexiCapture state and search for bottlenecks, the Performance Monitor utility can be used.

FlexiCapture counters

FlexiCapture own counters are located in the category FlexiCapture.
Values of the counters are recorded by the Processing Server, so the counters are available in the computer where this server is installed.

As the Processing Server is a 32-bit application, the Performance Monitor utility must be run in 32-bit mode when used in 64-bit computers. For this, enter the following command in the command line (cmd.exe):

```
mmmc /32 perfmon.msc
```

By default, recording counters by the Processing Server is disabled. To enable counters recording, do the following:

1. Start the Processing Server console. For this, on the computer where the service of the Processing Server is started, execute the following command in the command line (cmd.exe):
   ```
   FlexiBRSvc.exe please obey
   ```

2. Set the value of the server parameter `PerformanceCounting` to `true`. For this, execute the command:
   ```
   set PerformanceCounting=true
   ```

3. Check the state of the `PerformanceCounting` parameter with the “view” command.

4. Quit the Processing Server Manager console using the “quit” command.

**Note:** To view help on the Processing Server Manager console, use the “help” command.
Description of counters:

1. **ASCT Count** – Application Server Communication Threads count. The number of running threads used for interaction with the Application Server. By default, takes values from 1 to 3. Each thread opens its session. Additional threads are started if, for the existing threads, latency (**ASCT Latency**) has reached two seconds.

2. **ASCT Latency** – Application Server Communication Thread latency (ms). The latency of processing requests in the flows of interaction with the Processing Server. The downtime of queuing requests measured in milliseconds.

   The smaller this value, the better. The ideal value is zero. Values within 1000 (1 second) are the norm.

   When the counter value reaches 2 seconds and the maximum number of threads is not running one more thread is started. When the value reaches 30000 (30 seconds), the Processing Server switches to a critical mode: it stops taking new tasks and retrieving information about projects on the server until the queue is unloaded. Therefore, a long stay is the state > 30 seconds is generally undesirable.

3. **Primary Thread Latency** – a delay in the response of the Processing Server measured in milliseconds. This index shows the responsiveness of the server. The increase of this index leads to “freezing” of the Processing Server Monitor.

   It is desirable that the value of this counter be minimal. This counter is the most critical. The server does not have auto-adjusting by the value of this counter. A response delay of more than 10 seconds is highly undesirable. As a rule, an excessive growth of this counter means that a network interaction with some station is extremely slow.

   **Note:** With the “view” command of the Processing Server console, you can output the “Server lag time” value that corresponds to the maximum of the Primary Thread Latency and ASCT Latency values.

4. **Task Queue Size** the size of the buffer allocated for the task. Includes all tasks displayed in the Processing Server Monitor as well as some of the tasks deleted over the past 5 minutes. This counter does not matter much in terms of administration however it can be used to monitor the correlation between the number of tasks in the Processing Server and the occupied memory.

5. **Cores Count** – the number of cores in all started (which are in a state Started) Processing Stations of FlexiCapture.

6. **Free Cores** – the number of free cores in all started (which are in a state Started) Processing Stations of FlexiCapture. Allows you to estimate, whether there are enough cores in FlexiCapture.
7. **Pending Tasks** – the number of tasks taken into processing by the Processing Server, but not yet assigned to a Processing Station. Such tasks are displayed in the Processing Server Monitor in a **Pending** state. Note that this number is not the number of tasks queued in the Processing Server.

   This number may be proportional to the total number of cores in the system, but it should not be increased indefinitely. Admissible value: up to 2 tasks per 1 core.

8. **Running Tasks** – the total number of tasks being executed in the Processing Server at the moment.

9. **Export Count, Import Count, Recognition Count, Other Tasks Count** – the number of corresponding tasks (export, import, recognition and others) over the past 5 minutes.

10. **Export Time, Import Time, Recognition Time, Other Tasks Time** – an average execution time for the corresponding tasks (export, import, recognition and others) over the past 5 minutes.

11. **Modification Server Locks Count** – the number of documents that are blocked for executors. The counter applies for the Processing Station only.

**System counters**

Sometimes, insufficient performance can be caused by the used hardware. In order to determine whether the hardware complies with the load and whether it has bottlenecks, system performance counters must be used. Counter used for different system components are described below.

**RAM**

1. **Memory: Available Mbytes** – the amount of physical memory (RAM), in bytes, available to processes running on the computer. RAM consists of the physical memory and a swap file. If the RAM in the system is not enough, the paging mechanism is used which can lead to slowdown.

2. **Paging File: Usage** – the use of paging. Data and code in the memory are divided into pages. On Intel, one page is equal to 4096 byte. Paging is the process of moving pages between the physical to virtual memory. Excessive movement of pages from disk into memory and vice versa can lead to severe CPU load. Such a situation may look like a problem with the processor or disk.

3. **Memory: Committed Bytes** – the committed memory. The memory reserved in the file pagefile.sys in case you need to dump the contents of physical memory to disk. The amount of allocated memory of the process characterized the amount of memory actually consumed by it. The amount of allocated memory is limited to the size of the paging file. The limit of the amount of allocated memory in the system (Memory: Commit Limit) is determined by how much memory can be allocated to processes without increasing the size of the paging file. The counter shows the total amount of allocated memory for all processes that is the actual amount of memory used by the system.

4. **Memory: Page Faults/sec** shows how often the data are outside the working set. The working set is the physical memory (RAM) visible to a process or a program. Page faults occur when the program requests a code or data page which is not in the working set and must be found elsewhere. Includes soft page faults and hard page faults. A soft page fault is a situation when the program requests a page which is memory but out of working set. In this case, restoring data from disk is not required. A hard page fault is a situation when the program requests a page which is not in the physical memory (RAM) and must be restored from disk. Faults of this type are the best to show the presence of bottlenecks in the memory configuration. More than 5 faults per second show that RAM should be increased.

5. **Memory: Page Input/sec** total number of pages read from disk to resolve hard page faults. Comparing this counter with Page Faults/sec shows the number of soft page faults.

6. **Memory: Pages/sec** – total number of pages read from disk and written to disk. This is the sum of Page Outputs/sec (the number of pages that had to be written to the disk to make room in RAM for other pages as a result of page fault) and Page Inputs/sec. The admissible average value is 0 – 20. The Pages/sec value of more than 5 per second indicates a bottleneck in memory configuration. Comparing this counter with Page Faults/sec gives an idea about the number of soft page faults and hard page faults.

It is also recommended to monitor the memory occupied by the following processes:

- **FlexiBrSvc.exe** – the process of the Processing Server and the Processing Station. If both services are installed on the computer (not recommended), they can be distinguished by PID specified for the corresponding services.
- **w3wp.exe** – IIS working processes.
- **sqlserv.exe** – SQL Server process

**Processor**
It is recommended to exclude memory and other bottlenecks that load the processor before diagnosing a bottleneck caused by a process.

Identify processes that occupy more than 80% of CPU time. If the length of the queue is more than 2 threads, the bottleneck in operation of the system is probably caused by this process.

1. **System: % Processor Time: _Total** – time (in percentage of the whole working time) during which all processors were busy. For one processor, it is equal to the counter Processor: % Processor Time. For multiple processors, an average counter value is used. The counter measures how much time (in %) the system spends processing Idle processes and subtracts this percentage from 100 %. The resulting value corresponds to the percentage of time, the processor actually spent working on productive threads.

2. **Processor: % Total Processor Time:** - the same as System: % Processor Time, though measured for each processor.

3. **System: Processor Queue Length** shows how many threads are ready in the processor queue, but not currently able to use the processor. Does not include a thread that is processed at the moment. Shows the current (not an average) value. The counter value of more than 2 indicates a bottleneck.

**Disk**

1. **LogicalDisk or PhysicalDisk: % Disk Time** – indicates how busy the disk is (% of working time).

2. **LogicalDisk or PhysicalDisk: Current Disk Queue Length** – measures the number of the I/O transactions that are waiting to be handled. Contains the current value (not an average). The counter value of more than 2 for a long period of time indicates a bottleneck.

3. **Disk Bytes / sec:** - the number of bytes transferred to the disk per second. The primary measure of the disk performance. The counter value of more than 2 for a long period of time indicates a bottleneck.

4. **Avg Disk Bytes / Transfer:** - the average number of bytes transferred per read of the disk system. This is an indicator of the disk efficiency. The higher the value, the better.

**Network interface**

1. **Network Interface: Current Bandwidth** – bandwidth of the network interface.

2. **Network Interface: Bytes Total/sec** – load of the network interface. If the load of the network interface is 75% or more of the bandwidth, then the network interface is a bottleneck. It is also worth comparing the load with the base mode in which the work was stable.

3. **Network Interface: Output Queue Length** – network interface. If an average value of the counter is more than two, it means that the network interface (or the capacity of the network infrastructure) cannot cope with transferring data provided by the server. That is, server provides data at a faster rate than the network interface is able to pass.

**IIS**

1. **W3SVC_W3WP: Active Threads Count: FlexiCapture 11 Web Services** – the number of active threads in IIS.

2. **WebService: Current ISAPI Extension requests: Default Web site** (if the FlexiCapture Application Server has not been transmitted to a different site by the user) – the queue of requests to be processed in IIS. If the queue is significantly (2-3 times) larger than the number of active threads in IIS, then IIS is likely to be a bottleneck. You should take into account that the bottleneck may also be the SQL Server that executes requests for a long time causing the queue of requests to increase.

**SQL Server**

SQL Server has a large number of performance counters which can help you not only estimate the server load, but also, for example, investigate the behavior in case of custom settings (non-optimal settings can increase the load on the server which can be visible with the help of the counters).

We recommend using the main counter responsible for the server performance:

1. **SQLServer: SQL Statistics: Batch Requests/Sec counter** – this counter measures the number of batch requests received by SQL Server per second and allows you to monitor the load of processors in the server. In general, more than 1000 batch requests per second tells of a very high load on the SQL Server and may mean that if you have not experienced a shortage of CPU resources, you may run into it in the near future. Of course, this number is relative, and the more powerful hardware you have, the more batch requests per second can be handled by SQL Server. In terms of network bottlenecks, a typical network card with a capacity of 100 Mb/s can only handle about 3000 batch requests per second. Under similar loads, you may need to switch to a network card with capacity of 1 Gb/s.
You can also use the counter **SQLServer: Databases: Transaction/Sec: _Total** to measure the total activity of SQL Server. However, it measures only the activity within the transaction, not the whole activity, which can lead to erroneous results.

You can also use the following counters to analyze the amount of memory consumed by the server and estimate whether the server has enough memory:

2. **SQLServer: Memory Manager — Target Server Memory (KB)** shows how much memory is required for SQL Server. If the value of this parameter matches the value of **SQLServer: Memory Manager — Total Server Memory (KB)**, it means that SQL Server has enough memory.

3. **SQLServer: Memory Manager — Total Server Memory (KB)** shows how much memory SQL Server actually uses. If the value of this parameter matches the value of **SQLServer: Memory Manager — Target Server Memory (KB)**, it means that SQL Server has enough memory. However, if the value of this counter is smaller, it means that more available memory is needed to optimize performance of SQL Server.
Logging

Administration and Monitoring Console logs
The event and error logs available in the Administration and Monitoring Console are the main logs that register errors that occur in the system in general. These logs record all errors that occur during document processing and affecting the processing and all events that occur during document processing. To view the logs, select Monitoring→Event Log and Monitoring→Error Log in the Administration and Monitoring Console. In the settings of the Administration and Monitoring Console, you can specify what type of events should be logged. Logging all events is not recommended, as it can lead to a significant increase in the size of the database during an intensive processing.

Task processing logs on the Processing Servers
The Processing Server logs the processing of the tasks. The list of the active tasks and their logs can be accessed via the Processing Server Monitor. To view a task log, select Actions→View Log... when selecting the task.

OS event logs on the servers
The server components (Application Server, Processing Server, Licensing Server) and processing stations log errors and warnings in the local event log of the operating system under which they are running (section: Application, sources: FlexiCapture Executer for processing stations, FlexiCapture Processing Server for Processing Server, FlexiCapture Web Services for Application Server and Fine Objects for Licensing Server). These logs can be accessed by the administrators both locally and remotely via the standard Event Viewer tool of the MMC console. The local OS event log records not only processing errors, but also all errors in the operation of the server components not directly related to the processing of documents. This log will list processing errors even if the Application Server is inaccessible at the time of error and the error cannot be logged in the ABBYY FlexiCapture log.
Working with Clusters

ABYY FlexiCapture supports clusters.
There are two important benefits of using clusters:
- Fault tolerance: in case of failure of one of the servers, the request will be executed by another server.
- Distributed workloads: query processing is distributed among cluster nodes. This improves performance and increases fault tolerance.

The following ABBYY FlexiCapture 11 components can be installed on clusters:
- Processing Server
- Licensing Server
- Application Server

ABYY FlexiCapture can work with Microsoft SQL Server installed on failover cluster.

The Processing Server and the Licensing Server are installed on failover clusters.
The Application Server, the Administration and Monitoring Console, and the Web Stations, which use IIS (Internet Information Services), are installed on NLB (Network Load Balancing) clusters.

**Note.** Failover and Network Load Balancing clusters cannot work on the same computer.

The following figure displays the clusterization of ABBYY FlexiCapture Servers and Microsoft SQL Server:

The deployment of the Processing Server and the Licensing Server on clusters is described below in this guide.

**Setting Up the Processing Server**

Failover clusters are used for clustering the Processing Server.
A detailed guide to failover clustering can be found on the [Microsoft website](https://microsoft.com).

**Deploying the Processing Server on a Failover Cluster**

In this section, you will find step-by-step instructions for setting up the server on a failover cluster.

**Note.** The addresses, computer names, domain names, etc. used below are not mandatory and may be changed by the administrator.

**Note.** The following server configuration is intended only for local use in a local area network.

**Important!** The names of servers, services, and shared folders must not contain spaces.
Basic Configuration of the Failover Cluster

In this example, the processing server is deployed on a FOC cluster (FOC.cluster2008r2.ru). The cluster uses a network with the address 192.168.0.0/24 and the domain cluster2008r2.ru.

The cluster consists of two nodes: Node1 and Node2.

Addressing in the Cluster

The Node1 and Node2 nodes have two network interfaces: one interface belongs to the 192.168.0.0/24 network, the other may belong to your local area network (for example 10.0.0.0/16). The data storage only interfaces with the 192.168.0.0/24 network and is available only to the cluster nodes (i.e. Node1 and Node2).

Both networks are available to the cluster FOC.cluster2008r2.ru. Cluster traffic should only be allowed in the designated network 192.168.0.0/24 for security and workload balancing reasons. External users can access the data storage through requests to Node1 and Node2. In order to allow cluster traffic in the 192.168.0.0/24 network, open the Failover Cluster Manager, select Cluster Network in the Networks group, and choose Enabled in the Cluster Use column (see the screenshot below).

<table>
<thead>
<tr>
<th>Interface</th>
<th>Network</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage</td>
<td>192.168.0.1/24</td>
<td>Centralized storage</td>
</tr>
<tr>
<td>Node1</td>
<td>192.168.0.11/24</td>
<td>Cluster node</td>
</tr>
<tr>
<td>Node2</td>
<td>192.168.0.12/24</td>
<td>Cluster node</td>
</tr>
<tr>
<td>FOC</td>
<td>192.168.0.10/24</td>
<td>Cluster address</td>
</tr>
<tr>
<td>FC11ProcServer</td>
<td>192.168.0.2/24</td>
<td>Address of the service running in the cluster</td>
</tr>
</tbody>
</table>

Domain users

To set up domain user accounts:

1. Create two domain users, for example cluster2008r2\node1admin and cluster2008r2\node2admin.
2. Give administrator rights to cluster2008r2\node1admin on Node1 and to cluster2008r2\node2admin on Node2.

**Important!** These user accounts will only be used for working with ABBYY FlexiCapture in a failover cluster to ensure correct usage of shared network resources.

**Important!** Clustering requires the use of domain accounts. It is not possible to work under a local user account.

**Adding the ABBYY FlexiCapture 11 Service to the Cluster**

Install ABBYY FlexiCapture on Node1 and Node2, then create a [network folder](#) for the FlexiCapture service.

**Creating the Service**

Complete the following steps to create the service:

1. Right-click the **Services and Applications** group and choose **Configure a Service or Application...**

![Configure a Service or Application](#)

2. Select **Generic Service** from the list of services and click **Next**.

![Add Service](#)
3. Choose ABBYY FlexiCapture 11 Processing Server from the list of available services and click **Next**.

4. Enter the name of the service (FC11ProcServer in this example) to be used by clients and choose an address (192.168.0.2 in this example). Click **Next**.
5. Choose the shared drive you created for centralized storage and click Next.

6. Specify the registry key:
   - `HKEY_LOCAL_MACHINE\SOFTWARE\ABBYY\FlexiCapture\11.0` – for x32 systems
- HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ABBYY\FlexiCapture\11.0 – for x64 systems (see the screenshot below)

7. Click **Next** to confirm the settings.

8. To complete the creation of the service in the cluster, click **Finish**.
Creating a Shared Folder for the Processing Server Service

1. The cluster nodes Node 1 and Node 2 need a shared folder where to store their temporary files. To create a shared folder for the nodes, right-click the service you created (in this case FC11ProcServer) and choose Add a Shared Folder. In this example, the shared drive H:\ was used (this drive was earlier created at the Storage computer). In the Location field, enter the name of the folder you want to share, for example H:\Cluster Temp.
2. To edit access permissions, select the **Yes, change NTFS permissions** option and click the **Edit Permissions...** button.
3. To add new users, click **Add**. The **Select Users, Computers, Service Accounts, or Groups** dialog box will open. Add the two previously created users from the `cluster2008r2` domain and click **OK**.

4. Give full access permissions for the folder `\FC11ProcServer\ClusterTemp` to the users `node1admin` and `node2admin`. 
5. Choose SMB as the protocol over which users will access the folder.
6. In the Description field, provide a description for the folder which will help you with support and maintenance in the future. Click the **Advanced**... button to edit access permissions for SMB-based access.
7. Click Add... The Permissions for ClusterTemp window will open. Add the two previously created users from the cluster2008r2 domain and click OK. Give the users node1admin and node2admin full access permissions for \FC11ProcServer\ClusterTemp.
8. If you want to publish the SMB share to a DFS namespace, select the corresponding option and click **Next**.
9. Check your settings and click **Create** to create the shared folder.
10. Click **Close** to complete the creation of the shared folder.
You have successfully completed the Provision a Shared Folder Wizard.

- Share over SMB: Success
Setting Up the Cluster Nodes

Next you must set up the cluster nodes Node1 and Node2. The instructions below apply to Node1. The other nodes are set up identically.

Setting Up the ABBYY FlexiCapture Processing Server Local Service

To set up the service, complete the following steps:

1. Enter the following command in the command line (cmd.exe):
   
   ```cmd
   sc config ABBYY.ProcServer.FlexiCapture.11 binpath= "%systemdrive%\Program Files (x86)\ABBYY FlexiCapture 11 Servers\FlexiBRSvc.exe /service -stationType:server -inifile:\fc11proceserver\ClusterTemp\ServerSettings.xml"
   
   This command changes the default settings for the process **ABBYY.ProcServer.FlexiCapture.11**, which is launched from the file "%systemdrive%\Program Files (x86)\ABBYY FlexiCapture 11 Servers\FlexiBRSvc.exe," and sets the path to the following file that contains the settings for the Processing Server: 
   \fc11proceserver\ClusterTemp\ServerSettings.xml. Now the file ServerSettings.xml will be stored in the shared folder and will be available to all nodes in the cluster.
   
2. Find the service **ABBYY FlexiCapture 11 Processing Server** in the list of services (Start -> Administrative Tools -> Services). Right-click the service and choose **Properties**.

3. Make sure that the parameters you typed in the command line are displayed in the **Path to executable** field.
4. Go to the **Log On** tab. For Node1, change the user NetworkService to node1admin. For Node2, change the user NetworkService to node2admin. Click **OK**.
Changing the variable `%appdata%`

The service ABBYY.ProcServer.FlexiCapture.11 creates and stores session data in the location referenced by the variable `%appdata%`. The users node1admin and node2admin must have the same folder specified for `%appdata%` in order for the service to switch between cluster nodes.

**Important!** For the user `cluster2008r2\node1admin`, the variable `%appdata%` must be changed on Node1. For the user `cluster2008r2\node2admin`, the variable `%appdata%` must be changed on Node2.

You can change the variable `%appdata%` through the command line or directly in the registry.

**To change `%appdata%` through the command line:**

1. Enter the following command in the command line (cmd.exe):
   ```
   REG ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders" /v AppData /t REG_EXPAND_SZ /d \FC11ProcServer\ClusterTemp, where \FC11ProcServer\ClusterTemp should be replaced with the path to your folder.
   ```

2. Confirm that you want to change the AppData folder if it already exists.

3. Repeat steps 1 and 2 for Node2.

**To change `%appdata%` directly:**

1. Find the key `HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders` in the registry.

2. If it doesn’t already exist, create a `REG_EXPAND_SZ` type variable with the name `AppData` in this key. Set its value to `\FC11ProcServer\ClusterTemp`.

3. Repeat steps 1 and 2 for Node2.

**Connecting the Processing Server Monitor**

To connect the Processing Server Monitor, choose a node to which the FC11ProcServer service will belong, then open the Processing Server Monitor on any computer in your LAN and add the clustered Processing Server.
Setting Up the Licensing Server

The Licensing Server service can be added to the cluster identically to the Processing Server service. The same serial number should be activated (the serial number must support at least two activations). The serial number must not change depending on the node provided by the Licensing Server.

The stations must be restarted after the service switches between the cluster nodes. The Processing Server stops and automatically starts in 5 minutes. The remote stations continue working with their tickets if the same serial number is used for all of the cluster nodes.

A separate log file with page use statistics is created on each cluster node in the folder %allusersprofile%\ABBYY\FlexiCapture11\Licenses. To obtain summary statistics, the values from all of the nodes must be added. If a serial number which allows two activations is activated on the nodes Node1 and Node2, then pages are counted for the Node1 license when Node1 is running and for Node2 license when Node2 is running. If the page limit specified for the serial number is 100 pages, then, besides the main 100 pages, 100 more pages are added to be used when working on the other node.

Setting Up the Application Server (and clustering the Administration and Monitoring Console and Web Stations)

The ABBYY FlexiCapture 11 Application Server can be deployed on an NLB cluster to balance workloads and speed up query processing.

Detailed information about Network Load Balancing technology can be found on the Microsoft website.

Setting Up an NLB Cluster for the Application Server

In this section, you will find step-by-step instructions for setting up an NLB cluster for the Application Server. The Administration and Monitoring Console and Web Stations are clustered together with the Application Server. A detailed overview of NLB cluster settings can be found on the Microsoft website.

Note. The addresses, computer names, domain names, etc. used below are not mandatory and may be changed by the administrator.

Setting Up the Cluster

To set up the cluster, complete the following steps:

1. Install the Application Server on each cluster node. The database, File Storage Folder, Processing Server, Licensing Server, and Application Server clients must be located on a different computer, which must be accessible to all nodes in the cluster.

2. In Windows Features, add Network Load Balancing to each node in the cluster. This can be done by clicking the Add Features link in the main window of the Server Manager (Start -> Administrative Tools -> Server Manager).

3. Assign an IP address to the cluster via which the cluster can access the nodes as a unit. (This is a virtual cluster address.)

If a single network interface is used for client/cluster traffic and other network traffic on the nodes (as is usual in Multicast mode), each host in the cluster must have a dedicated IP address (in addition to the virtual address, which is common to all cluster nodes). A host will use its dedicated IP address instead of the virtual cluster address for incoming connections to the cluster nodes over Telnet, SSH and other protocols, and for outbound connections from the cluster nodes.

All cluster nodes must receive all incoming cluster traffic. The balancing algorithm determines which cluster node should respond to a given query. The choice between Unicast and Multicast depends on your network configuration.
4. You can use the Performance Monitor for IIS (accessible through the toolbar of the Microsoft Management Console (MMC)) to monitor node activity. In the Web Service object, for each node, add the ISAPI Extension Requests/sec counter for Default Web Site (this is the location of the Application Server in the IIS).

Selecting the Unicast or Multicast Method of Distributing Incoming Requests
The choice between the Unicast and Multicast methods depends on your network configuration. A detailed description of the two methods can be found on the Microsoft website.

Balancing Workloads in the Cluster, Setting Up Hosts
You can set up cluster traffic to be balanced and filtered by ports.

ABBYY FlexiCapture requires the TCP protocol for its operation. There are two filtering modes: Single Host and Multiple Host.

- Single host
  This mode provides fault tolerance, but does not allow load balancing. Only one cluster node is active at a time.

- Multiple host
  Traffic from a predefined range of ports is handled by the node with the highest priority in the cluster. All cluster nodes function simultaneously.
  This mode provides both workload balancing and fault tolerance.
  Traffic from a predefined range of ports is balanced among nodes. You can also set the Affinity parameter to:

  - None (not recommended)
    If this option is selected, multiple connections (TCP sessions) from a single client can be handled by different nodes.
  - Single (recommended)
    If this option is selected, all connections from a single client are handled by one node.
  - Network (Class C) (recommended)
    If this option is selected, all queries from the TCP/IP Class C address space are handled by one node. This may be necessary if there is a proxy server between the client and the cluster.

Setting Up the Application Server
Complete the following steps to set up the Application Server:
1. Create a shared folder that can be accessed by all of the nodes in the cluster.
2. Install Microsoft SQL Server. Microsoft SQL Server must be available to all cluster nodes.
3. Install the Application Server on all cluster nodes.
4. On the first cluster node, run the Administration and Monitoring Console and create a database and specify a shared storage.
5. On each of the remaining cluster nodes, run the Administration and Monitoring Console and connect to the database you created.
   Important! For this operation, SQL authentication must be used.
6. On the SQL Server, give full access permissions for the database to all users on all cluster nodes under whose accounts IIS is running (the World Wide Web Publishing Service must be running in the service list). Permissions for the first node are given automatically when the database is created, other permissions must be given manually. By default, IIS runs under the user Network Service. In this case, assuming IIS is running on computer NodeN, you must give full access permissions to the user DomainName\NodeN\User on the SQL Server.
7. If the Application Server is not unavailable in the cluster, but PING requests still reach the cluster, check if IIS is available in the cluster. To do this check, place a static *.html file in the folder %systemdrive%\inetpub\wwwroot (usually this folder already contains an iisstart.htm file) and open this file in a browser: \ClusterAddress\iisstart.htm. Pay attention to the proxy server settings in your browser when opening the file.

Running Server Application Clients
We recommend that you place all cluster nodes in one domain and run Application Server clients under domain user accounts.

Running Application Server clients under local user accounts is not recommended for the following reason.
In the usual (i.e. non-clustered) configuration of the Application Server, the following authentication method may be used: on the computer where the Application Server is installed, a local user is created, with its own user name and password; now any client may connect to the Application Server under this user’s account.
In a clustered configuration, the Application Server that processes client requests may be placed on different computers, and the actual user name will change accordingly: on the computer node1, the user name will be node1\User, while on the computer node2, the user name will be node2\User. This may disrupt the operation of the system.
Running Application Server clients under domain users avoids this problem.
To connect clients on remote computers which are not in the domain, you can use basic authentication and a user account in the domain to which the cluster belongs. Suppose the clustered Application Server is in the cluster domain and the computer of the verification operator is not in this domain. All you need to do is create in the cluster domain an account for the user cluster\VerificationOperator and communicate the account name and password to the verification operator. Now the verification operator will be able to connect to the Application Server using this account and basic authentication on the Verification Station.

**Note.** To use basic authentication for clients, be sure to enable basic authentication for the folder FlexiCapture11\Server in IIS. Otherwise, users will get HTTP 401 error when attempting to connect.
Technical Support

Should you have any questions regarding the installation and use of ABBYY FlexiCapture, please contact the ABBYY technical support service or the technical support service of the ABBYY partner from which you obtained the software. For contact details, see the Technical Support section of the ABBYY website at www.abbyy.com.